## Contents

<table>
<thead>
<tr>
<th>Preface</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>About This Book</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>What Is Apple Remote Desktop?</td>
</tr>
<tr>
<td>5</td>
<td>Using This Guide</td>
</tr>
<tr>
<td>7</td>
<td>Where to Find More Information About Apple Remote Desktop</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 1</th>
<th>9</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Apple Remote Desktop</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Administering Computers</td>
</tr>
<tr>
<td>18</td>
<td>Supporting Users</td>
</tr>
<tr>
<td>23</td>
<td>Finding More Information</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2</th>
<th>25</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting Up</td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>System Requirements for Apple Remote Desktop</td>
</tr>
<tr>
<td>26</td>
<td>Setting Up an Apple Remote Desktop Administrator Computer</td>
</tr>
<tr>
<td>28</td>
<td>Setting Up Client Computers With Mac OS X 10.2 Installed</td>
</tr>
<tr>
<td>32</td>
<td>Setting Up Client Computers With Mac OS X 10.3 Installed</td>
</tr>
<tr>
<td>36</td>
<td>Creating a Custom Client Installer</td>
</tr>
<tr>
<td>38</td>
<td>Understanding Access Types</td>
</tr>
<tr>
<td>44</td>
<td>Considerations for Managed Clients</td>
</tr>
<tr>
<td>44</td>
<td>Configuring the Administrator Software</td>
</tr>
<tr>
<td>48</td>
<td>Setting Up the Network</td>
</tr>
<tr>
<td>49</td>
<td>Getting the Best Performance</td>
</tr>
<tr>
<td>50</td>
<td>Maintaining Security</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 3</th>
<th>53</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administering Computers</td>
<td></td>
</tr>
<tr>
<td>54</td>
<td>Finding and Adding Clients to ARD Computer Lists</td>
</tr>
<tr>
<td>57</td>
<td>Making and Managing Lists</td>
</tr>
<tr>
<td>58</td>
<td>Installing Software Using ARD</td>
</tr>
<tr>
<td>62</td>
<td>Upgrading Software</td>
</tr>
<tr>
<td>63</td>
<td>Copying Files</td>
</tr>
<tr>
<td>66</td>
<td>Creating Reports</td>
</tr>
<tr>
<td>77</td>
<td>Maintaining Systems</td>
</tr>
<tr>
<td>79</td>
<td>Managing Computers</td>
</tr>
<tr>
<td>84</td>
<td>Automating Functions</td>
</tr>
</tbody>
</table>
Chapter 4 93 Interacting With Users

94 Controlling

97 Observing

100 Sending Messages

102 Sharing Screens

Appendix A 105 Reference

105 Computer Scanner Icons

106 ARD Status Icons

106 TCP and UDP Port Reference

107 Report Field Definitions Reference

114 PostgreSQL Schema Sample
Preface

About This Book

What Is Apple Remote Desktop?
Apple Remote Desktop (ARD) is easy-to-use, powerful, open standards-based, desktop management software for all your networked Macs. IT professionals can remotely control and configure systems, install software, offer live online help to end users, and assemble detailed software and hardware reports for an entire Mac network.

You can use Apple Remote Desktop to:
• Manage client computers and maintain, upgrade, and distribute software
• Collect more than 200 system-information attributes for any Mac on your network. Store the results in an SQL database and view the information using one of several hardware or software reports.
• Provide help and remote assistance for users when they encounter problems
• Interact with users by sending text messages, observing and controlling users’ screens, and sharing their screens with other client users

With Apple Remote Desktop software, you can access your office computer, documents, and applications while you’re away from the office. Used in a classroom, Apple Remote Desktop enhances the learning experience and allows teachers to monitor and control students’ computers. In corporate environments, it’s the ideal solution for managing remote systems, reducing administration costs, and increasing productivity.

Using This Guide
The ARD Administrator’s Guide contains chapters to help you use Remote Desktop. It contains overviews and explanations about ARD’s features and commands. It also explains how to install and configure ARD on clients, how to administer client computers, and how to use Remote Desktop to interact with computer users.

In addition, this guide is provided on the ARD installation disc and on the Apple Remote Desktop support website as a fully searchable, bookmarked PDF file. You can use Apple’s Preview application or Adobe (Acrobat) Reader to browse the contents of this guide as well as search for specific terms, features, or tasks.
Remote Desktop Help is available using Help Viewer. To open Remote Desktop Help, choose Help > Remote Desktop Help. The help files contain the same information found in this guide, and are useful when trying to accomplish a task when this guide is unavailable.

**Notation Conventions**
This guide and Remote Desktop Help contain step-by-step procedures to help you use ARD’s commands effectively. In many tasks shown in this manual and in Remote Desktop Help, you need to choose menu commands, which look like this:

- Choose Edit > Clear.

The first term after Choose is the name of a menu in the Remote Desktop menu bar. The next term (or terms) are the items you choose from that menu.

**Terminal Command Conventions**

<table>
<thead>
<tr>
<th>Notation</th>
<th>Indicates</th>
</tr>
</thead>
<tbody>
<tr>
<td>monospaced font</td>
<td>A command or other Terminal text</td>
</tr>
<tr>
<td>$</td>
<td>A shell prompt</td>
</tr>
<tr>
<td>&lt;anglebrackets&gt;</td>
<td>A displayed value that depends on your configuration or settings</td>
</tr>
</tbody>
</table>

Commands or command parameters that you might type, along with other text that normally appears in a Terminal window, are shown in this font. For example:

You can use the `doit` command to get things done.

When a command is shown on a line by itself as you might type it in a Terminal window, it follows a dollar sign that represents the shell prompt. For example:

```
$ doit
```

To use this command, type “doit” without the dollar sign at the command prompt in a Terminal window, then press the Return key.
Where to Find More Information About Apple Remote Desktop

For additional information related to Apple Remote Desktop, try these resources.

- You’ll find more information in the ARD Read Me file and on the Apple Remote Desktop website:
  http://www.apple.com/remotedesktop
- You can find the most recent edition of the Administrator’s Guide at:
  http://www.apple.com/server/documentation
- The Apple Remote Desktop Support website provides a database of technical articles about product issues, usage, and implementation:
  http://www.apple.com/support/remotedesktop
- To provide feedback about ARD, visit the feedback page:
- For details about how to join the ARD Mailing list, visit:
  http://lists.apple.com/mailman/listinfo/remote-desktop
- To share information and learn from others in online discussions, visit the ARD Discussions Forum:
  http://discussions.info.apple.com/appleremotedesktop
- For more information about WBEM/CIM, go to:
  http://www.dmtf.org
- For more information about PostgreSQL go to:
  http://www.postgresql.org
Using Apple Remote Desktop

Apple Remote Desktop helps you keep Macintosh computers and the software running on them up to date and trouble free. And it lets you interact directly with Macintosh users to provide instructional and troubleshooting support.

This chapter describes the main aspects of ARD’s administration and user interaction capabilities and tells you where to find complete instructions for using them.

Administering Computers
ARD lets you perform a wide range of client hardware and software administration activities remotely, from an administrator computer (the computer on which administrator software resides):

- Keep users’ software up to date by using ARD to deploy software and related files to client computers.
- Create reports that inventory the characteristics of client computer software and hardware.
- Use ARD’s remote administration capabilities to perform housekeeping tasks for client computers.
You can administer client computers individually, but most ARD features can be used to manage multiple computers at the same time. For example, you may want to install or update the same applications on all the computers in a particular department. Or you may want to share your computer screen to demonstrate a task to a group of users, such as students in a training room.

To manage multiple computers with a single action, you define ARD computer lists. A computer list is a group of computers that you want to administer similarly. Setting up computer lists is easy; you simply import the identity of computers from files, or network scans.

A particular computer can belong to more than one list, giving you a lot of flexibility for multicomputer management. A computer can be categorized by its type (laptop, desktop), its physical location (building 3, 4th floor), its usage (marketing, engineering, computing), and so forth.

Once you’ve set up computer lists, you can conduct most of the computer administration activities described next for groups of client computers.
Deploying Software
ARD lets you distribute software and related files to client computers from your ARD administrator computer or from a computer running Mac OS X Server.

Distributing Install Packages
You can distribute and automatically install packages in .pkg and .mpkg formats. ARD lets you install software and software updates on one or more client computers without user interaction or interruption, or even if no user is logged in. After installation, ARD erases the installer files. If the computers need to be restarted, as they do following an operating system update, you can restart them from ARD.
For example, you can use Apple Software Update to download an iCal update or an operating system update to a test computer. If the update works as expected and introduces no compatibility issues, copy the install package to the administrator computer to distribute to computers that need upgrading. Note that this approach conserves Internet bandwidth, because only one copy of the package needs to be downloaded.

You can also use ARD to deploy new versions of computational software to Xserve computers in a cluster node.

You can use the PackageMaker tool from Apple's Developer Tools to create your own install packages, such as when you want to:
• Distribute school project materials or business forms and templates
• Automate the installation of multiple install packages
• Deploy custom applications

Before performing remote installations, you can send an ARD text message to notify users, perhaps letting them know that you'll be using ARD to lock their screens at a particular time before you start the installation.

**Using Network Install Images**

You can also distribute and install software, including the Mac OS X operating system, by using Network Install images.

On Mac OS X Server, use the Network Image Utility to create a Network Install image. You can create the image by cloning a system that's already installed and set up or by using an install disc or image downloaded using Apple Software Update. If you choose to auto-install, you won't have to interact with each computer. On the ARD administrator computer, set the startup disk of remote client systems to point to the Network Install image, and then remotely reboot the clients to initiate installation.

Before initiating installations that require computers to be restarted afterwards, send an ARD text message to client users to notify them of a pending installation. For example, tell users you'll log them off at 5:00 PM to install an operating system update.

**Using NetBoot Images**

Another kind of system image you can create using Mac OS X Server is a NetBoot image. Like a Network Install image, a client computer uses NetBoot images to start up. Unlike a Network Install image, the boot software is not installed on the client system. Instead, it resides on a remote server. It is recommended you use a NetBoot image that has ARD installed and configured. Otherwise, administering the computer using ARD after NetBooting is impossible.
Client computers that boot from a NetBoot image get fresh system environments every time they start up. For this reason, using NetBoot images is useful when a particular computer is shared by several users who require different work environments or refreshed work environments, or when you want to start a new experiment or use a different computing environment in a cluster node.

You use ARD to set the startup disks of client systems to point to the NetBoot image, and then restart the systems remotely using ARD. Users can also choose a NetBoot image for startup by using the Startup Disk pane of System Preferences. With just a few clicks you can reconfigure all the computers in a lab or cluster without having to manually restart and configure each computer individually.

**Distributing Configuration Files**
Many of the core Mac OS services rely on the settings in configuration files. Use ARD to distribute configuration files when you need to reconfigure services.

For example, if you add a new network printer, you can update the printer list of all computers in the area by using ARD to copy an updated CUPS configuration file and the PPD (printer definition) files to the computers.

You can also use ARD to distribute AppleScript files that automate PDF workflows, or job instructions for computational clusters.

**Using UNIX Shell Scripts**
You can use ARD to distribute and run UNIX shell scripts on client computers.

For example, a script can mount an AFP server volume, from which it downloads a disk image to client computers. The script might also download an install package and then perform a command-line install.

On an Xserve in a cluster node, you could also run a script that mounts an Xserve RAID disk designed for high throughput and then downloads large data sets for processing.

**Distributing Drag-and-Drop Applications**
You can distribute and install self-contained (drag-and-drop) applications by copying them to one or more client computers. Use this approach, for example, to distribute Safari application updates.

**Verifying Installations**
To check whether an installation has been completed successfully, use ARD’s remote control capabilities.

For example, you can start an application remotely, or search for particular files. You can also use the File Search report to verify that all files for an application are installed correctly.
Taking Inventory
ARD lets you capture data describing the attributes of client computers, then generate reports based on the data.

You specify how often you want to capture data, the data you want to capture, and the computers you want to profile. You can collect data just before generating a report if you need up-to-the-minute information. Or you can schedule data to be collected by ARD at regular intervals and stored in its built-in SQL (Structured Query Language) database for use on an as-needed basis.

You can also specify where you want the database to reside—on the local administrator computer, or on a server where the ARD administration software is installed and always running, so data can be captured on an ongoing basis.

Using the collected data, ARD generates reports tailored to your specifications.
File Search Report
Use the File Search report to search client systems for specific files and folders and to audit installed applications.

This report can help you find out how many copies of a particular application are in use so you don’t violate license agreements.

Software Version Report
Use the Software Version report to make sure that all users have the latest application versions appropriate for their systems.

Software Difference Report
Use the Software Difference report to detect application versions that are out of date, nonstandard, or unacceptable for some other reason. Or you can learn whether a user has installed an application that shouldn’t be installed.

System Overview Report
The System Overview report makes visible a wide variety of client computer characteristics. Using this report you can review information about a client’s AirPort setup, computer and display characteristics, devices, network settings, system preferences, printer lists, and key software attributes.

There are numerous uses for this report, such as identifying problems or verifying system configurations before installing new software, or determining how many devices of a particular type (such as scanners) reside in a particular lab.

Hardware Reports
Several reports focus on details about particular hardware used by client computers—hard disks, FireWire devices, USB devices, network interfaces, memory, and PCI cards.

Use these reports to determine, for example, which computers need more memory, which computer has the fastest processor speed, and how much free space is left on a particular disk.

Administration Settings Report
Use the Administration Settings report to determine which ARD administration privileges are enabled or disabled for you in the Sharing or Remote Desktop pane of System Preferences on individual client computers.

Network Test Report
A network test report helps you measure and troubleshoot the communication between your administrator computer and your client computers.
Use this report to help identify reasons for network communication problems that could affect ARD. For example, if you’re unable to copy items to particular client computers from the administrator computer, you may find you have a bad connection to the computers. Using this information can help you isolate the problem to a particular cable or hub.

**Generating Your Own Reports**

Because the ARD database is in standard SQL format, you can also use your favorite SQL scripts to query, sort, and analyze the collected data. In addition, you can export data from the database into a file so you can import it for viewing in a different program, such as a spreadsheet application.
Housekeeping
ARD provides several ways to remotely control client computers for housekeeping activities, which you can conduct using one or more ARD windows.

Managing Power Settings
Use ARD to manage the power settings of client computers.

For example, you may need to have all computers turned off during maintenance of a power generation unit or during a holiday shutdown. You could send an ARD text message reminding users to shut down their computers at a particular time. Any computers still running when you need to start maintenance can be detected and shut down remotely with ARD.
Locking Computer Screens
You can lock the screens of client computers for specified durations when you don’t want the computers to be used. For example, you may need to perform network maintenance and want to make sure that computers don’t use the network for a few hours.

You can display a custom picture and/or text messages on screens while they’re locked to let users know when they’re available again.

Reclaiming Disk Space
Periodically empty the Trash on client computers to conserve disk space.

Automating Periodic Maintenance
Use UNIX shell scripts to automate periodic maintenance, such as checking permissions or deleting log files.

Controlling Screens
Use ARD’s remote screen control to conduct activities on the desktop of Xserve computers, or use graphical applications on them. ARD replaces the need for KVM (keyboard/video/mouse) switches for accessing Xserve computers without a monitor attached.

You can also remotely control a user’s computer to help determine reasons for slow performance or other problems the user is experiencing.

Changing Startup Disks
Change the startup disk of a client computer to perform diagnostic or troubleshooting activities.

For example, start up a computer using a server-based NetBoot image that’s been set up for troubleshooting. When you’re finished, reset the startup disk to the original boot volume.

Managing Shared Computers
On computers that are shared among users, check for files that need to be deleted between user logins, close applications, log users off, or perform other activities needed to prepare computers for the next users.

Supporting Users
ARD lets you interact with users from your administrator computer in these ways:

• **Provide help:** respond to users who need help by using ARD to receive user requests and to remotely diagnose and fix problems.
• **Interact:** conduct instructional interactions with students in a school or corporate training environment—from controlling or observing student screens to sharing your screen with all your students to perform a demonstration.
Providing Help Desk Support
When a user is having trouble, ARD provides several ways to interact with the user and his or her computer to diagnose and fix the problem.

Requesting Help
A user can discreetly notify you of the problem by sending a request for help using an ARD text message.

Users initiate requests using the commands in the menu that appears when they click the ARD icon in the menu bar. A notification on the administrator computer alerts you to the message, and you can use several techniques to obtain more information or troubleshoot the problem.

Chatting With the User
Conduct two-way ARD text communication with the user to obtain more information.

Screen Monitoring
Use ARD to observe the user's screen if you need more details to understand the problem.
**Screen Controlling**
Use ARD to control the user’s screen in order to diagnose and hopefully fix the problem. You may have unlimited control, or a user can grant you temporary guest access so you can control his or her computer only during troubleshooting.

There are several levels of control available. You can take complete control of the user’s computer, or you can share control of the keyboard and mouse with the user.

**Screen Sharing**
If the problem is caused by incorrect actions by the user, share your screen with the user as you demonstrate the correct way to perform the action.

**Using Reports**
Use hardware and software reports as diagnostic tools to determine whether the client computer setup is part of the problem. For example, if a user can’t save his or her work, the storage report can help you determine whether it’s a disk space issue.

**Deploying New Software or Files**
If software or configuration settings are part of the problem, use ARD to copy new configuration files, install packages, or copy other items to client computers.
Interacting With Students
ARD helps instructors teach more efficiently by letting them interact with student computers individually or as a group.

Using Text Messages
Send ARD text messages to communicate with students. For example, notify them that a classroom activity will start soon or that they have 10 minutes to finish an examination.

Monitoring Student Computers
View student computer screens on your computer, so you can monitor student activities or assess how well they’re able to perform a particular task. You can also monitor the applications running on any student’s computer.

Sharing Screens
Display your screen or a student’s screen on other student computers for training and demonstration purposes.

Controlling Screens
Show students how to perform tasks by controlling their screens from your computer, opening applications and using files as required.
Locking Screens
Lock student screens to prevent students from using their computers when you want them to focus on other activities.

Terminating Computer Use
Remotely log students out or shut down their computers at the end of a class or school day.

Distributing and Collecting Files
Distribute handouts electronically, at a time that won’t disrupt class activities or when they’re needed for the next class activity, and collect homework files.

Automating Website Access
Open a webpage on all student computers. Drag a URL from Safari to your desktop, then copy it to student computers and open it in Safari. You can also copy files and open them in the appropriate applications on student computers.

Providing One-to-One Assistance
Provide help when a student needs it, conducting private and discreet computer-to-computer interactions as required.
### Finding More Information

You’ll find detailed instructions for performing the tasks highlighted in this chapter—and more—throughout this manual.

<table>
<thead>
<tr>
<th>To learn more about</th>
<th>See information for</th>
<th>Starting on page</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARD administration</td>
<td>Administration privileges</td>
<td>page 36</td>
</tr>
<tr>
<td></td>
<td>Administrator computers</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>Computer lists</td>
<td>Creating computer lists</td>
<td>page 57</td>
</tr>
<tr>
<td>Deploying software</td>
<td>Installing software</td>
<td>page 56</td>
</tr>
<tr>
<td></td>
<td>Upgrading software</td>
<td></td>
</tr>
<tr>
<td>Distributing files</td>
<td>Copying files</td>
<td>page 63</td>
</tr>
<tr>
<td>Taking inventory</td>
<td>Data collection options</td>
<td>page 66</td>
</tr>
<tr>
<td></td>
<td>Auditing software</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Auditing hardware</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Network responsiveness</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Customizing reports</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Exporting report data</td>
<td></td>
</tr>
<tr>
<td>Housekeeping tasks</td>
<td>Deleting items</td>
<td>page 77</td>
</tr>
<tr>
<td></td>
<td>Emptying the Trash</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Setting startup volumes</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Renaming computers</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Sleeping and waking</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Locking screens</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Logging users out</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Restart and shutdown</td>
<td></td>
</tr>
<tr>
<td>Automating tasks</td>
<td>Configuring data gathering</td>
<td>page 77</td>
</tr>
<tr>
<td></td>
<td>Scheduling tasks</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Using UNIX shell scripts</td>
<td></td>
</tr>
<tr>
<td>Using ARD text messages</td>
<td>Text messages</td>
<td>page 104</td>
</tr>
<tr>
<td>Controlling screens</td>
<td>Controlling</td>
<td>page 94</td>
</tr>
<tr>
<td>Observing screens</td>
<td>Observing</td>
<td>page 97</td>
</tr>
<tr>
<td>Sharing screens</td>
<td>Share screens</td>
<td>page 102</td>
</tr>
</tbody>
</table>

Additional information can be obtained at several Apple websites:

- For information about NetBoot and Network Install, go to www.apple.com/server/documentation/ and download the system imaging administration guide.
- For information about PackageMaker, go to www.developer.apple.com and search for PackageMaker.
Setting Up

To use Apple Remote Desktop, install the administration software on the administrator computer first, and then install and enable the client software on the computers you want to manage.

This chapter describes the main aspects of setting up and configuring ARD for system administration and user interaction and gives complete instructions for setting up. You can learn about:

- System Requirements for Apple Remote Desktop on page 23
- Setting Up an Apple Remote Desktop Administrator Computer on page 26
- Setting Up Client Computers With Mac OS X 10.2 Installed on page 28
- Setting Up Client Computers With Mac OS X 10.3 Installed on page 32
- Creating a Custom Client Installer on page 36
- Understanding Access Types on page 38
- Considerations for Managed Clients on page 44
- Configuring the Administrator Software on page 44
- Setting Up the Network on page 48
- Getting the Best Performance on page 49
- Maintaining Security on page 50

System Requirements for Apple Remote Desktop

Administrator and client computers:

- eMac, iMac, iBook G3 or G4, PowerBook G3 or G4, Power Mac G3, G4 or G5, Xserve G4 or G5
- Mac OS X versions 10.2.8 and 10.3 or later
- Mac OS Extended (HFS+) formatted hard disk
- For observing and controlling other platforms: a system running VNC-compatible server software.

NetBoot and Network Install

- Mac OS X Server 10.3 with NetBoot and Network Install services enabled
Network Requirements
• Ethernet (recommended), AirPort, FireWire, or other network connection
  See “Setting Up the Network” on page 48 for more information.

Setting Up an Apple Remote Desktop Administrator Computer
If you already have Apple Remote Desktop version 1.2 and existing ARD computer lists on a different computer from the one on which you’ll install ARD 2, you first need to transfer the existing ARD computer lists to the new computer.

Otherwise, go to “Installing the Administrator Software” on page 27.

Transferring Old Computer Lists to a New Administrator Computer
If you are installing ARD 2 on a computer different from the current administrator computer, you need to move your existing computer lists to the new administrator computer before installing version 2.

These instructions only apply when moving ARD 1.2 administrator computer lists to a new computer.

Throughout these instructions, the computer with the original lists is the “source computer.” The computer that will have ARD 2 installed is the “target computer.”

To transfer the computer lists:
1 Open Keychain Access (in /Applications/Utilities) on the source computer.
2 Choose File > New Keychain.
3 Name the new keychain, and click Create.
4 Enter a password for the new keychain.
   This is a temporary password that you will use to retrieve the information in the keychain. Do not use your login or other sensitive password.
5 If necessary, click Show Keychains to show the administrator keychain.
6 Select the source computer’s main keychain.
   If the keychain is locked, unlock it and authenticate.
7 Select only the ARD entries in the Keychain.
8 Drag the ARD entries to the newly created keychain.
9 Provide the source computer keychain password for each entry.
10 Quit Keychain Access on the source computer.
Copy the newly created keychain from the source computer (~/.Library/Keychains/<keychain name>) to the same location on the target computer.

You can copy the keychain over a network, or use a removable storage drive.

On the target computer, open Keychain Access in the Finder.

Choose File > Add Keychain.

Select the keychain that was copied from the source computer, and click Open.

If necessary, click Show Keychains to show the keychains.

Unlock the newly imported keychain, using the password designated for that keychain.

Select the ARD entries.

Drag the ARD entries to the main keychain on the target computer.

Provide the temporary keychain password for each entry.

Quit Keychain Access on the source computer.

When you open ARD on the new computer, you will notice the computer lists from the old computer are available.

**Installing the Administrator Software**

To set up ARD on administrator computers, you install the software on the computer you plan to use to administer remote computers. Then, you open the application and create a main list of computers.

**To install Apple Remote Desktop on an administrator computer:**

1. Insert the Apple Remote Desktop disc.

2. Double click the ARD install package and follow the onscreen instructions.

The application Remote Desktop will be installed in the Applications folder.

3. Open Remote Desktop (in the Applications folder).

   The Remote Desktop Setup Assistant appears.

4. Enter the ARD serial number.

   The serial number can be found on the Apple Remote Desktop Welcome document that came with your software.

5. Click Continue.

   If ARD 2 client software is not already present, the assistant asks if you want to install it. Click OK to continue.
Enter a Remote Desktop password and verify it. The Remote Desktop password is used to encrypt names and passwords of client computers for ARD. You can store this password in your keychain for convenience, or you can require that the password be entered each time you open Remote Desktop.

Click Done.

The main application window appears.

If ARD 1.2 was previously installed (or if you transferred computer lists from another administrator computer), all the existing computer lists are available in the new window. Update and configure your clients using the instructions in Upgrading Existing Client Software on Mac OS X 10.2 or Upgrading Existing Client Software on Mac OS X 10.3 Using ARD.

If no version of ARD was previously installed, you must enable and configure the client computers before Remote Desktop can administer them.

Uninstalling the Administrator Software
To remove the administrator software completely, you must remove the application, the encrypted list of computer login names and passwords, and the client information database.

To remove the administrator software:
1. Drag the Remote Desktop application to the Trash.
2. Empty the Trash.
3. Delete the ARD database from /var/db/RemoteManagement/ using the following command in the Terminal application:
   ```bash
   $ sudo rm -rf /var/db/RemoteManagement
   $ sudo rm /Library/Preferences/com.apple.RemoteDesktop.plist
   $ rm ~/Library/Preferences/com.apple.RemoteDesktop.plist
   ```

Setting Up Client Computers With Mac OS X 10.2 Installed
The following section contains information on installing Apple Remote Desktop 2 on computers running Mac OS X 10.2 Jaguar. See the appropriate instructions, depending on whether you're setting up clients for the first time or upgrading existing ARD clients.

Installing the Client Software on Mac OS X 10.2 for the First Time
To install the client software on the computers you plan to use with Apple Remote Desktop, use the ARD administration software to create a client software installer. You need the name and password of a user with administrator privileges on the client computer to install the package.
To install the client software for the first time:

1. Create the custom client install package.
   For detailed instructions, see "Creating a Custom Client Installer" on page 36.

2. Copy and install the package on the client computers.
   There are several ways to do this. For example, you can:
   - Distribute the package by removable media, such as a CD
   - Copy the installer to the clients over the network using file sharing
   - Copy the installer to the clients using command-line tools like scp (if ssh is enabled), and use Apple's command-line installation tool, "installer," to install the package remotely. This process is described in detail in "Upgrading Existing Mac OS X 10.2 Client Software Using ssh" on page 23.

   Warning: Custom installer packages that create login names contain sensitive password data. Take care to store such custom installers securely.

Upgrading Existing Client Software On Mac OS X 10.2

For Mac OS X 10.2 Jaguar computers using Apple Remote Desktop client software version 1.2 or later, you can use the Upgrade Client Software feature to update client software with Remote Desktop's built-in features. If you choose not to use Remote Desktop's Upgrade Client feature, you can use the process described in "Installing the Client Software on Mac OS X 10.2 for the First Time," above, to upgrade Jaguar clients manually.

Upgrading Existing Mac OS X 10.2 Client Software Using ARD

To upgrade ARD clients, find them in your ARD computer lists, or with a network scan.

To upgrade existing computers:

1. Open Remote Desktop.
2. Select a computer list.
3. Select one or more computers in the Remote Desktop window.
4. Choose Manage > Upgrade Client Software.

Upgrading Existing Mac OS X 10.2 Client Software Using ssh

You may not be able to use Apple Remote Desktop's administration software to upgrade existing Jaguar clients to ARD 2. The clients may have software older than version 1.2, for example. If the clients have ssh enabled (called Remote Login in System Preferences), and are available on the network, you can still upgrade the client computers.

You still need to use the ARD administration software to create a custom installer package. You also need the login name and password of a user with administrator privileges on the client computer.
To upgrade existing client software via ssh:

1. Create the custom client install package.
   For detailed instructions, see “Creating a Custom Client Installer” on page 36.

2. Make sure Remote Login is selected in the Sharing pane of System Preferences on the client computer.

3. Open Terminal.

4. Copy the installer package to the client computer by typing:
   
   ```
   $ scp -r <path to installer package> <user>@<host>:<path to package destination>
   ```
   For other `scp` options, see its man page.

5. Log in to the client computer using the `ssh` command-line tool.
   
   ```
   $ ssh <user>@<host>
   ```
   For other `ssh` options, see its man page.

6. On the client computer, install the package by typing:
   
   ```
   $ sudo installer -pkg <path to package> -target /
   ```
   For other `installer` options, see its man page.

Preparing Mac OS X 10.2 Clients for Administration

To prepare a client for administration, after installing or updating the Apple Remote Desktop client software on the computer, you activate ARD and grant access privileges to the computer by using the ARD pane of the computer’s System Preferences. If you chose to have the privileges set and ARD enabled when you created the custom installer package, your computers are already prepared.

Note: You can skip this step if you create a custom installer that automatically enables your desired client settings.

If you did not create an ARD user login or define ARD administrator access privileges when you created the custom installer package, you need to configure your clients. You set access privileges separately for each user account on the computer for which you want the ARD administrator to be able to log in and take command of the computer. Follow the steps in this section to set access privileges on each client computer that uses Mac OS X 10.2 Jaguar.

To make changes on a Mac OS X client, you must have the name and password of a user with administrator privileges on that computer.
To set administration privileges on each computer:

1. On the client computer, open System Preferences and click Apple Remote Desktop. If necessary, enter the user name and password of a user with administrator privileges on that computer.

2. To activate the ARD client, make sure to select “Make Apple Remote Desktop active on this computer.”

3. Select the checkbox of each user account that you want enabled for ARD.

4. Select a listed user whose access privileges you want to change, and then make the changes you want to the access privileges. Your changes take effect immediately. See [User Privileges and Permissions Security](#) on page 50 for more information.

5. Repeat for additional users whose access privileges you want to change.

6. If you wish, enter information in any or all of the four Computer Information fields. This information appears in ARD System Overview reports. For example, you can enter an inventory number for the computer, a serial number, or a user’s name and telephone number.

**Disabling the Client Software in Mac OS X 10.2**

You may want to temporarily disable Apple Remote Desktop on a Mac OS X 10.2 Jaguar client without removing the software.

**To disable the client software on a Jaguar client computer:**

1. On the client computer, open System Preferences and click Apple Remote Desktop. If necessary, enter the user name and password of a user with administrator privileges on that computer.

2. Deselect “Make Apple Remote Desktop active on this computer.”

3. Deselect the checkbox of each user account that was enabled for ARD. Alternatively, you can open the Terminal application and use the `kill` command to stop first the ARDHelper process, then the ARDAgent process.

**Uninstalling the Client Software From a Mac OS X 10.2 Computer**

To remove Apple Remote Desktop client software from Mac OS X 10.2 clients, you need to remove a number of software components from the client system.

**Warning:** It is not recommended to uninstall the client software. Disabling the client software is sufficient to stop ARD system activity. See [Disabling the Client Software in Mac OS X 10.2](#) for instructions.
To uninstall client software from Jaguar:
1 Open Terminal (in /Applications/Utilities).
2 With root privileges (sudo or su -l root), type the following commands:
   $ rm -rf /System/Library/CoreServices/Menu\ Extras/RemoteDesktop.menu
   $ rm -rf /System/Library/CoreServices/RemoteManagement/
   $ rm -rf /System/Library/PreferencePanes/ARDPref.prefPane
   $ rm -rf /System/Library/StartupItems/RemoteDesktopAgent/
   $ rm /Library/Preferences/com.apple.ARDAgent.plist
   $ rm /Library/Preferences/com.apple.RemoteManagement.plist

Setting Up Client Computers With Mac OS X 10.3 Installed
The following section contains information on installing Apple Remote Desktop 2 on computers running Mac OS X 10.3 Panther. Since ARD 1.2 is installed automatically on the clients when you install Mac OS X 10.3, all ARD 2 installations are upgrade installations, even if you are setting up clients for the first time.

Installing the Client Software on Mac OS X 10.3 Manually
Apple Remote Desktop client software version 1.2 or later is automatically installed when you install Mac OS X 10.3 or later on a client computer. You can easily upgrade your clients using ARD. See "Upgrading Existing Client Software on Mac OS X 10.3 Using ARD" on page 33 for more information.

If you don't want ARD to update your clients using the Upgrade Client Software feature, you can perform a manual update.

To update the client software on the computers you plan to use with ARD, use the ARD administration software to create a client software installer package. You need the name and password of a user with administrator privileges on the computer to install the package.
To manually update the client software:
1 Create the custom client install package.
   For detailed instructions, see Creating a Custom Client Installer on page 36.
2 Copy and install the package on the client computers.
   There are several ways to do this. For example, you can:
   • Distribute the package by removable media, such as a CD
   • Copy the installer to the clients over the network using file sharing
   • Copy the installer to the clients using command-line tools like scp (if ssh is enabled), and use Apple's command-line installation tool, "installer," to install the package remotely. This process is described in detail in Upgrading Existing Client Software on Mac OS X 10.3 Using ssh on page 34.

Warning: Custom install packages that create login names contain sensitive password data. Take care to store such custom installers securely.

Upgrading Existing Client Software on Mac OS X 10.3 Using ARD
Apple Remote Desktop client software version 1.2 or later is automatically installed when you install Mac OS X 10.3 on a client computer. You can use ARD's Upgrade Client Software feature to upgrade the clients to version 2.

Before upgrading clients, you need to prepare the clients for administration by enabling ARD and granting ARD Administrator privileges.

To upgrade existing client software using ARD:
1 Enable Remote Desktop sharing on the clients, and grant ARD administrator privileges.
   See Preparing Mac OS X 10.3 Clients for Administration on page 34.
2 If the computers are not in an existing Remote Desktop computer list, find the client computers using an ARD scanner.
   See Finding and Adding Clients to ARD Computer Lists on page 54 for more information.
3 Select the client computers to be upgraded.
4 Choose Manage > Upgrade Client Software.
5 Click Upgrade.
Upgrading Existing Client Software on Mac OS X 10.3 Using ssh
You may not be able to use Apple Remote Desktop’s administration software to upgrade existing Panther clients to ARD 2. If the clients have ssh enabled (called Remote Login in System Preferences), and are available on the network, you can still upgrade the client computers.

You still need to use the ARD administration software to create a custom installer package. You also need the login name and password of a user with administrator privileges on the client computer.

To upgrade existing client software via ssh:
1 Create the custom client install package.
For detailed instructions, see Creating a Custom Client Installer on page 36.
2 Open Terminal.
3 Copy the installer package to the client computer by typing:

   $ scp -r <path to installer package> <user>@<host>:<path to package destination>

For other scp options, see its man page.
4 Log in to the client computer by typing:

   $ ssh <user>@<host>

For other ssh options, see its man page.
5 On the client computer, install the package by typing:

   $ sudo installer -pkg <path to package> -target /

For other installer options, see its man page.

Preparing Mac OS X 10.3 Clients for Administration
To prepare a client for administration, you activate Apple Remote Desktop on the client computer and set ARD administrator access privileges to the computer by using the Sharing pane of the computer’s System Preferences. You set access privileges separately for each user account on the computer. Follow the steps in this section to set access privileges on each client computer.

Note: You can skip this step if you create a custom installer that automatically enables your desired client settings.

To make changes on a client, you must have the name and password of a user with administrator privileges on the computer.
To set administration privileges on each computer:
1. On the client computer, open System Preferences and click Sharing.
   If necessary, enter the user name and password of a user with administrator privileges on that computer.
3. Click Access Privileges.
4. Select the checkbox of each user account that you want enabled for ARD administration.
5. Select a listed user whose access privileges you want to set, and then make the changes you want to the access privileges. Your changes take effect immediately.
   See User Privileges and Permissions Security on page 50 for more information.
6. Repeat for additional users whose access privileges you want to set.
7. If desired, enter information in any or all of the four Computer Information fields.
   This information appears in ARD System Overview reports. For example, you can enter an inventory number for the computer, a serial number, or a user’s name and telephone number.
8. Click OK.
9. To activate the ARD client, make sure to select the Apple Remote Desktop checkbox, or select Remote Desktop and click Start.

Disabling the Client Software in Mac OS X 10.3
You may want to temporarily disable Apple Remote Desktop on a Mac OS X 10.3 Panther client without removing the software.

Warning: Because ARD is part of the default Panther installation, do not remove the ARD client components.

To disable the client software on a Panther client computer:
1. On the client computer, open System Preferences and click Sharing.
   If necessary, enter the user name and password of a user with administrator privileges on that computer.
3. Click Access Privileges.
4. Deselect the checkbox of each user account that you enabled for ARD administration.
5. Click OK.
7. Quit System Preferences.
Creating a Custom Client Installer
To install the Apple Remote Desktop client software on computers, you use the ARD administrator application, Remote Desktop, to create a custom client installer. The custom client installer not only installs the ARD system software, but can create users on the client computer with their ARD privileges already assigned. You’ll use an assistant to create a custom client installer. Any values set in the custom installer will apply to all the computers that receive the installation.

While creating a custom installer, you will have a chance to create new ARD administrator login names with passwords, and automatically set ARD access privileges and preferences.

**To create the client installer:**

1. Open Remote Desktop.
2. Choose File > Create Client Installer.
   The Custom Installer Setup Assistant appears.
3. Choose to create a custom installer and click Continue.
   If you choose not to create a custom installer, you can create a basic installer that sets no preferences on the client computer.
4. Click Continue to begin creating a custom installer.
5. Choose whether to start Remote Desktop sharing at system startup.
   This changes the setting found in the Sharing pane of System Preferences (for Mac OS X 10.3 or later) or the Remote Desktop pane of System Preference (for Mac OS X 10.2).
6. Choose whether to hide or show the ARD menu bar icon.
7. Click Continue.
8. Choose whether to create a new user for ARD login. Click Continue.
   New users can be used to grant ARD administrator privileges. Creating a new user does not overwrite existing users or change existing user passwords.
   If you choose not to create a new user, skip to step 10 after clicking Continue.
9. Add a new user by clicking Add and filling in the appropriate information.
   Click OK after adding each user, and click Continue when you’re ready to go on.
10. Choose whether to assign ARD administrative access privileges to Directory Services groups.
    If you choose to do so, select “Set authorized groups to.” Edit the groups, if necessary.
    See [ARD Administrative Access Using Directory Services](#) on page 33 for more information on using this method to grant ARD administrative access.
Choose whether to assign ARD administrative access privileges to specific users. Click Continue.

If you choose not to assign administrative access privileges, skip to step 14.

Click Add to designate a user to receive ARD access privileges.

Provide the user's short name and set the privileges as desired.

See "User Privileges and Permissions Security" on page 50 for more information.

Click OK after each user, and click Continue when you're ready to go on.

Choose whether to allow temporary guest control by requesting permission on the client computers.

See "ARD Guest Access" on page 44 for more information.

Choose whether to allow non-Apple VNC viewers to control the client computers, and click Continue.

See "Virtual Network Computing (VNC) Access" on page 43 for more information.

If desired, select and enter information in any or all of the four System Data fields.

This information appears in ARD System Overview reports. For example, you can enter an inventory number for the computer, a serial number, or a user's name and telephone number.

Choose whether to allow OpenWBEM tools to request data from the client computers.

See "OpenWBEM Access" on page 44 for more information.

Click Continue.

Select a location for the installer.

Click Continue to create the installer.

An installer package (.pkg file) is created in the designated location.

Click Done.
Understanding Access Types

There are several different ways to access Apple Remote Desktop clients. Some depend on ARD settings, and others depend on other client settings, or third-party administration tools. The following sections explain the various access types, their configuration, and their uses.

ARD Administrator Access

Access privileges allow an Apple Remote Desktop administrator to add computers to a list and then interact with them. If no access privileges are allowed on a client computer, that computer cannot be used with ARD. Access privileges are defined in the ARD section of the Sharing or Remote Desktop pane of the client computers’ System Preferences.

The recommended access privileges for a client computer depend on how it’s used.

- If the computer is used in a public area, such as a computer lab, you may want to allow administrators full access privileges.
- If the computer is used by one person, you may not want to give administrators full access privileges. Also, you may want a user that administers his or her own computer to take responsibility for creating passwords and setting the access privileges for the computer.

<table>
<thead>
<tr>
<th>Select</th>
<th>To allow administrators to</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;a user name&gt;</td>
<td>Select any other privileges. (If you select only this box, the administrator can see the client computer in the Computer Status window and include it in Network Test reports.)</td>
</tr>
<tr>
<td>Generate reports</td>
<td>Create hardware and software reports using the Reports menu.</td>
</tr>
<tr>
<td>Open and quit applications</td>
<td>Use these Manage menu commands: Open Application, Open Item, and Log Out.</td>
</tr>
<tr>
<td>Change settings</td>
<td>Use these Manage menu commands: Rename Computer and Set Network Startup.</td>
</tr>
<tr>
<td>Delete and replace items</td>
<td>Use these Manage menu commands: Copy Items, Install Package, and Empty Trash. Also delete items from report windows. This item must be enabled in order to use the Upgrade Client feature.</td>
</tr>
<tr>
<td>Send text messages</td>
<td>Use these Interact menu commands: Send Message and Chat.</td>
</tr>
<tr>
<td>Restart and shut down</td>
<td>Use these Manage menu commands: Sleep, Wake Up, Restart, and Shut Down. This item must be enabled in order to use the Upgrade Client Software feature.</td>
</tr>
</tbody>
</table>
ARD Administrative Access Using Directory Services
You can also grant Apple Remote Desktop administrative access without enabling any local users at all by enabling group-based authorization. When you use specially named groups from your Directory Services master domain, you don’t have to add users and passwords to the client computers for ARD access.

When Directory Services authorization is enabled on a client, the user name and password you supply when you authenticate to the computer is checked in the directory. If the name belongs to one of the ARD access groups, you are granted the access privileges assigned to the group.

You must create groups in the Directory Services master domain named “ard_admin” and “ard_reports”. The groups have the following management privileges:

<table>
<thead>
<tr>
<th>Privilege</th>
<th>ard_admin</th>
<th>ard_reports</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generate reports</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Open and quit applications</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Change settings</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Copy items</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Delete and replace items</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Send messages</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Restart and shut down</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Control</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Observe</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Show being observed</td>
<td>x</td>
<td></td>
</tr>
</tbody>
</table>

Enabling Directory Services Group Authorization
In order to enable group-based authorization for Apple Remote Desktop access, you create the appropriate groups in your Directory Services’ master directory domain.

To complete this task, you need to be the Directory Services administrator and have access to your organization’s users and groups server.
To enable ARD authorization by group:
1 In your directory system, create two groups with the short names “ard_admin” and “ard_reports.”
2 Add users to the groups.
3 Make sure the clients to be administered are bound to your directory system.

When changing client settings or making a custom installer, choose to enable directory services authorization on the clients, and specify these groups.

**Getting an Administration Settings Report**
You can query active Apple Remote Desktop clients for a report on what commands they are accepting from your administrator authentication.

The report is a list of the ARD administrator access types with a “yes” or “no” to indicate whether it is available to you.

**To get an administration settings report:**
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Report > Administration Settings.
4 Click Get Report.

**Changing Client Administration Privileges**
Once the client computers are able to be administered, you can change the administrator access privileges for multiple computers simultaneously, using the Change Client Settings command. If you are using Directory Services to designate administration privileges, you don’t need to change the settings on the clients.

To make changes on a client, you must have the name and password of a user with administrator privileges on the computer. Additionally, you must already have the Control privilege.

*Note:* You do not have to make a selection on every page of the assistant. You can click Continue to move to the next set of settings.

**To change administration privileges on each computer:**
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Change Client Settings.

The ARD client assistant appears.
4 Choose whether to start Remote Desktop sharing at system startup.

This changes the setting found in the Sharing pane of System Preferences (for Mac OS X 10.3 or later) or the Remote Desktop pane of System Preferences (for Mac OS X 10.2).

5 Choose whether to hide or show the ARD menu bar icon.

6 Click Continue.

7 Choose whether to create a new user for ARD login. Click Continue.

New users can be used to grant ARD administrator privileges. Creating a new user does not overwrite existing users or change existing user passwords.

If you choose not to create a new user, skip to step 8 after clicking Continue.

8 Add a new user by clicking Add and filling in the appropriate information.

Click OK after adding each user, and click Continue when you’re ready to go on.

9 Choose whether to assign ARD administrative access privileges to Directory Services groups.

If you choose to do so, select “Set authorized groups to.” Edit the groups, if necessary.

See "ARD Administrative Access Using Directory Services" on page 39 for more information on using this method to grant ARD administrative access.

10 Choose whether to assign ARD administrative access privileges to specific users. Click Continue.

If you choose not to assign administrative access privileges, skip to step 13.

11 Click Add to designate a user to receive ARD access privileges.

12 Provide the user’s short name and assign the privileges as desired.

See "User Privileges and Permissions Security" on page 30 for more information.

Click OK after each user, and click Continue when you’re ready to go on.

13 Choose whether to allow temporary guest control by requesting permission on the client computers.

See "ARD Guest Access" on page 42 for more information.

14 Choose whether to allow non-Apple VNC viewers to control the client computers, and click Continue.

See "Virtual Network Computing (VNC) Access" on page 43 for more information.

15 If desired, select and enter information in any or all of the four System Data fields.

This information appears in ARD System Overview reports. For example, you can enter an inventory number for the computer, a serial number, or a user’s name and telephone number.
Choose whether to allow OpenWBEM tools to request data from the client computers. See [OpenWBEM Access on page 44](#) for more information.

Click Continue to change the clients’ settings.

The client configuration assistant contacts all of the selected computers and changes their administration settings.

**ARD Guest Access**

You can configure an Apple Remote Desktop client to give temporary, one-time access to an ARD administrator who does not have a login name or password for the client computer. Each time the ARD administrator would like to control the client computer, he or she must request permission from the remote client’s user.

**Warning:** Granting access to control a screen is the most powerful feature in ARD, and can be equivalent to unrestricted access.

**To allow guest access:**

1. On the client computer, open System Preferences and click Sharing.
   
   On Mac OS X 10.2 clients, select the Remote Desktop pane and skip to step 3.
   
   If necessary, enter the user name and password of a user with administrator privileges on that computer.


3. Click Access Privileges.

4. Select “Guests may request permission to control screen.”

5. Click OK.

**Command-Line ssh Access**

When you log in to a client remotely using ssh, you have the user privileges assigned to the login name and password. These may, or may not, include computer administrator privileges.

You can use ssh to access a client using a user account created for ARD, but you are limited to performing whatever tasks were allowed to that user when the account was created. Conversely, only the users specified in the ARD access privileges can access a computer using ARD. ARD privileges do not have to be the same as local computer administrator privileges.
Virtual Network Computing (VNC) Access

You can use Apple Remote Desktop to access a VNC server and view and interact with the server’s screen. VNC access is determined by the VNC server software. To access a VNC server, it is only necessary to know the IP address or fully qualified domain name and the password designated in the VNC server software.

This password does not necessarily correspond with any other password on the system, and is determined by the VNC configuration.

VNC access is similar to ARD’s Control command. It allows you to use your keyboard and mouse to control a VNC server across a network. It doesn’t give any other ARD administrator privileges except those of the currently logged in user.

Non-Apple VNC viewers can control ARD clients if the client allows it. Allowing a non-Apple VNC viewer access to an ARD client is less secure than using ARD to control the client. The VNC protocol does not encrypt keystrokes sent over the network, so sensitive information can be intercepted over the network.

**Warning:** Granting VNC access to control a screen is the most powerful feature in ARD, and can be equivalent to unrestricted access.

To allow VNC access:

1. On the client computer, open System Preferences and click Sharing. On Mac OS X 10.2 clients, select the Remote Desktop pane and skip to step 4.
   - If necessary, enter the user name and password of a user with administrator privileges on that computer.
3. Click Access Privileges.
4. Select “VNC viewers may control screen with the password.”
5. Enter a VNC password.

**Warning:** Do not use the same password as any local user or ARD login.
OpenWBEM Access
ARD clients can respond to WBEM (Web-Based Enterprise Management) tools that request data from client computers. WBEM is an emerging network protocol standard for desktop computer management. WBEM relies on HTTP and XML to offer a web-based approach for exchanging CIM (Common Information Model) data.

For further information about WBEM, see http://www.dmtf.org.

ARD uses OpenWBEM as a basis for its WBEM implementation.

To allow WBEM access:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Change Client Settings.
   The ARD client assistant appears.
4 Click Continue until you reach the System Data section of the assistant.
5 Select Set OpenWBEM Access.
6 Click Allowed.
   Click disallowed to stop WBEM access on the client computers.
7 Click Continue to change the clients’ settings.
   The client assistant contacts all of the selected computers and changes their settings.

Considerations for Managed Clients
If you plan on using Apple Remote Desktop and also restricting what applications can open on a managed client, you’ll need to make sure that ARD’s processes are allowed to run. A managed client is a client computer whose environment is governed by Mac OS X Server’s Workgroup Manager. The following options need to be enabled in Workgroup Manager’s client and group application preference settings:
• “Allow approved applications to launch non-approved applications”
• “Allow Unix tools to run”

Configuring the Administrator Software
You can configure Remote Desktop, the Apple Remote Desktop administrator application, to help you meet your work needs. Remote Desktop has an interface that is both flexible and functional.
Understanding the Remote Desktop Interface

Remote Desktop Main Window

The main window of Remote Desktop has a toolbar, a group of lists on the left, and the task history area at the bottom.

Master List
The Master List is a list of all client computers that you plan to administer. It includes all the clients you have authenticated to, as well as the client computers that you plan to authenticate to. Computers need to be in the Master List before you can command or administer them. If you have a 10-client license, the Master List can only contain 10 computers.

Scanner
Scanners find clients to add to the Master List. You can make new scanners and customize them for your needs.

See “Making a New Scanner” on page 56.

ARD Computer Lists
An ARD computer list is a list of computers you create to group computers in ways that are convenient for you. Any list is a subset of the client computers in the Master List that you have selected. If you add a computer directly to a computer list, it is added automatically to the Master List as well.
Saved Tasks List
This is a special list maintained by ARD. It shows any tasks you have saved or have scheduled to be performed later.

Task History Area
The task history area shows a list of recent tasks. You can inspect each task by double-clicking it.

Task Dialogs
When you double-click a task, a dialog appears to let you set task parameters or confirm the task.

Schedule button
View Target Computers button

Each task dialog is unique to its own task, but they contain some common buttons:

Schedule Button
When you click this button in a task dialog, you can set a time to perform the task as well as repeat the task.

See "Scheduled tasks" on page 86 for more information.

View Target Computers Button
When you click this button, a drawer appears, showing you what computers will participate in this task. You can remove computers from the drawer, or drag new computers into it.
Customizing the Remote Desktop Toolbar
The Remote Desktop application has a fully customizable toolbar, which provides a quick way to perform tasks. To perform a task, just click the appropriate icon in the toolbar. To show or hide the toolbar, click the toolbar button in the upper-right corner of the application window. You can add, remove, or rearrange the task icons in the toolbar to suit your needs.

To customize the application toolbar:
1 Choose Window > Customize Toolbar.
2 Drag your favorite toolbar items or the default set of items to the toolbar. To remove an item, drag it out of the toolbar. To rearrange items, drag them into the order you prefer.
3 Choose whether to display toolbar items as text, icons, or both. Selecting "Use Small Size" shrinks the items in the toolbar.

Setting Preferences for the Remote Desktop Application
In Remote Desktop preferences, you can select a number of options that effect how the administration application interacts with client computers.

![Preferences](image)

To open the Preferences window:
• Choose Remote Desktop > Preferences.

In the General pane, you can set:
• What double-clicking a client computer does (Get Info, Control, Observe, Text Chat)
• Whether to automatically open task progress in a separate window
• Whether to accept messages from client users
• Whether to use relative dates in reports (Yesterday, instead of month/day/year)
• Whether to allow control of the computer while Remote Desktop is active
• What warnings may appear when quitting the application
• A new master password
• A new serial number

In the Control/Observed pane, you can set:
• Whether control of the mouse and keyboard is shared with the client computer when the client is controlled
• Whether a remote screen is shown at its actual size in a window or if it shrinks to fit the window
• Whether remote screens are shown in color or black and white
• How many computers can be observed on one page
• Image quality for observing multiple screens

In the Data Collection pane, you can set:
• Where the saved data for reports resides
• Whether other ARD administrators can access your local report database

In the Restricted Access pane, you can set:
• Which features of Remote Desktop are available to non-administrator users
  See [limiting features in the Administrator Application on page 51]

Setting Up the Network
Your network configuration determines Apple Remote Desktop’s performance and usability. AirPort and AirPort Extreme networks offer slower performance than almost any Ethernet network. Therefore, file copying, client monitoring, and reporting will be slower over AirPort and AirPort Extreme connections. Network routers and firewalls also shape, direct, or block network traffic; these things can have an effect on ARD’s reliability and efficiency. Here are a few guidelines to keep in mind when setting up ARD on your network:
• The more AirPort clients are connected to a base station, the lower the bandwidth for each computer. AirPort Base Stations are not considered “switched networks.”
• Bonjour does not extend beyond the local subnet. Bonjour names do not resolve across routers like domain names do.
• Networks with switches have fewer collisions and packet errors than networks with hubs. This means greater reliability and speed.
• If network traffic will pass through firewalls, make sure you have a large Maximum Transmission Unit (MTU) setting (1200 or greater). Too small an MTU setting can result in black screens when sharing or sending screens.
• If you are going across a wide-area network (WAN), or metropolitan area network (MAN), make sure that the defrag bit is turned off in your router so packets don’t get chunked up. This can result in black screens when sharing or sending screens.
• NAT (Network Address Translation) networks (such as those that use the Mac OS X “Internet Sharing” feature) can pose configuration and access difficulties.
If you want to use Remote Desktop from behind a NAT router to access computers beyond the NAT router, you need to set TCP and UDP port forwarding for ports 3283 and 5900 to your administrator computer. Similarly, if you wish to access a client computer that is behind a NAT router, you need to set the router to forward TCP and UDP ports 3283 and 5900 to the client computer you wish to access.

**Note:** You can access only that one client computer.

**Using Apple Remote Desktop With Computers in an AirPort Wireless Network**

Using Apple Remote Desktop to observe or control client computers connected using AirPort wireless technology can sometimes result in impaired performance or cause communication errors to appear in the Computer Status window.

To get the best performance from ARD with computers in an AirPort wireless network:

- Make sure that all AirPort Base Stations and all ARD client computers have the latest versions of ARD software, AirPort software, and Mac OS software installed.
- Limit the number of clients that connect to an AirPort Base Station. AirPort clients on a base station receive all network communication packets sent to any one client on that base station. Although clients ignore packets that aren't addressed to them, CPU resources are used to identify and discard the packet.
- Display shared screens in black and white rather than in color.
- Don't connect the ARD administrator computer to the network via AirPort. Connect it directly to the Ethernet network to which your AirPort Base Station is connected.
- Configure your AirPort Base Station with a station density of High and increase the multicast rate to 11 Mbps using AirPort Admin Utility. Using the base station density and multicast rate settings limits the range of each AirPort Base Station's network, requiring client computers to be fewer than 50 meters from a base station.

**Getting the Best Performance**

To get the best performance when using the Share Screen, Observe, and Control commands:

- Reduce the use of animation on remote computers. For example, you can simplify Dock preference settings by turning off animation, automatic hiding and showing, and magnification effects.
- View the client’s screen in a smaller window when using the “fit to window” option.
- View the client’s screen with fewer colors.
- Use a solid color for the desktop of the screen you’re sharing.
- Share screens only on local networks. If you share a screen with a computer connected across a router, screen changes happen more slowly.
- Organize computers you’re administering using ARD into small groups, and close the administrator software when not in use. This helps reduce the number of status queries, thus reducing network traffic.
• Consider using switches instead of hubs.
• If you are going through routers, ensure that you have a high Maximum Transmission Unit (MTU) setting (typically 1200 or higher), and make sure that you don’t have the router fragmenting packets.

Maintaining Security
Remote Desktop can be a powerful tool for teaching, demonstrating, and performing maintenance tasks. For convenience, the administrator name and password used to access Remote Desktop can be stored in a keychain or can be required to be typed each time you open the application. However, the login name and password for each client computer are stored in the administrator’s preferences and are strongly encrypted.

Securing the Administrator Application
• Make use of User Mode to limit what non-administrator users can do with ARD. See “Limiting Features in the Administrator Application” on page 51.
• If you leave the Remote Desktop password in your keychain, be sure to lock your keychain when you are not at your administrator computer.
• Consider limiting user accounts to disallow the use of Remote Desktop. Either in a Managed Client for Mac OS X (MCX) environment, or using the Accounts pane in System Preferences, you can make sure only the users you designate can use Remote Desktop.

User Privileges and Permissions Security
• To disable or limit an administrator’s access to an ARD client, open System Preferences on the client computer and make changes to settings in the Remote Desktop pane in the Sharing pane of System Preferences. The changes take effect after the current ARD session with the client computer ends.
• Remember that ARD keeps working on client computers, as long as the session remains open, even after the agent user password is changed.

Password Access Security
• Never give the Remote Desktop password to anyone.
• Never give the administrator name or password to anyone.
• Use cryptographically sound passwords (no words found in a dictionary, 8 characters or more, and include letters, numbers and punctuation with no repeating patterns).
• Quit the Remote Desktop application when you have finished using it. If you have not stored the Remote Desktop password in your keychain, the application will prompt you to enter the administrator name and password when you open it again.
Physical Access Security
- If you have stored the Remote Desktop password in your keychain, make sure the keychain is secured, and the application isn’t running while you are away from the Remote Desktop window.
- If you want to leave the Remote Desktop application open, but need to be away from the computer, use a password-protected screen saver and select a hot corner so you can instantly activate the screen saver.

Limiting Features in the Administrator Application
Remote Desktop can operate in what is referred to as “User Mode.” User Mode is activated when a non-administrator user opens Remote Desktop to administer ARD client computers. The administrator of the computer with Remote Desktop installed can choose which features and tasks are available to non-administrator users.

User Mode is a great way to delegate administrative tasks, or give users only the features of Remote Desktop that they really use. For example, you may not allow non-administrators to copy or delete files, but you may want them to be able to observe client screens and send messages to client users.

You can choose to allow non-administrators to:
- Observe, control, and share screens
- Lock and unlock screens
- Send text messages and chat
- Sleep and wake client computers
- Log out users
- Restart and shut down computers
- Open files and applications
- Rename computers
- Generate reports and software searches
- Copy items from clients
- Copy items, delete items, and empty the Trash
- Create ARD custom installers
- Upgrade clients and change client settings
- Install packages
- Set the client computer’s startup volume
- Set the client’s data reporting policy
- Send UNIX commands

Each of these features can be enabled or disabled independently of each other. Otherwise, you can enable all of Remote Desktop’s features for non-administrator users.
To enable User Mode:
1 Make sure you are logged in as an administrator user.
2 Open Remote Desktop.
3 Choose Remote Desktop > Preferences.
4 Click the Restricted Access button.
5 Enable or disable features, as desired.
6 Close the Preference's window.

Authentication and Data Transport Encryption
Authentication to Apple Remote Desktop clients uses an authentication method which is based on a Diffie-Hellman Key agreement protocol that creates a shared 128-bit key. This shared key is used to encrypt both the name and password using the Advanced Encryption Standard (AES). The Diffie-Hellman Key agreement protocol used in ARD 2 is very similar to the Diffie-Hellman Key agreement protocol used in personal file sharing, with both of them using a 512-bit prime for the shared key calculation.

With Remote Desktop 2, keystrokes and mouse events are encrypted when you control Mac OS X client computers. This information is encrypted using the Advanced Encryption Standard (AES) with the 128-bit shared key that was derived during authentication.

Warning: If you are using ARD to manage computers over public networks, consider using a virtual private network (VPN) solution to protect your information.
Apple Remote Desktop allows you powerful administrative control. You can manually or automatically get detailed information about every computer, install software, and maintain systems from a single administrator computer.

This chapter describes the main aspects of ARD’s administration capabilities and gives complete instructions for using them. You can learn about:

- Finding and Adding Clients to ARD Computer Lists on page 54
- Making and Managing Lists on page 57
- Installing Software Using ARD on page 58
- Upgrading Software on page 62
- Copying Files on page 63
- Creating Reports on page 68
- Maintaining Systems on page 77
- Managing Computers on page 79
- Automating Functions on page 84
Finding and Adding Clients to ARD Computer Lists

Before you can audit, control, or maintain any client, you need to add it to an Apple Remote Desktop computer list. To find computers that aren’t on the local subnet, your local network’s routers and firewalls must be properly configured to pass TCP and UDP packets on ports 3283 and 5900.

ARD has four different methods of discovering possible clients: searching the local network, searching a range of IP addresses, using a specific IP address or domain name, and importing a list of IP addresses. Once you have found a potential client, you see the following information:

<table>
<thead>
<tr>
<th>Search column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(none)</td>
<td>Shows a Master List icon if the computer is already in your Master List.</td>
</tr>
<tr>
<td>(none)</td>
<td>Shows a small icon that shows what kind of access the client is capable of. See <a href="#">Computer scanner icons on page 103</a>.</td>
</tr>
<tr>
<td>Computer Name</td>
<td>The name given to the computer in the Sharing pane of System Preferences.</td>
</tr>
<tr>
<td>IP Address</td>
<td>The computer’s IP address, if any.</td>
</tr>
<tr>
<td>host name</td>
<td>The fully qualified domain name or Bonjour name of the computer, if any.</td>
</tr>
<tr>
<td>ARD Version</td>
<td>Apple Remote Desktop client software version.</td>
</tr>
<tr>
<td>Network Interface</td>
<td>How the client is connected to the network (Built-in Ethernet, AirPort, etc.) Appears in scanner lists only.</td>
</tr>
</tbody>
</table>

To add a computer to an ARD computer list, you first authenticate to the computer. Authenticated computers are found in the Master List in the Remote Desktop window. You can add a computer to the Master List without authenticating, but you will be unable to administer the client until you provide a valid login name and password.

Finding Clients by Searching the Local Network

When you select a local network scanner, ARD sends a subnet broadcast and Bonjour service broadcast to computers in the same subnet as the administrator computer. All possible clients on the local subnet appear in a list on the left side of the Remote Desktop window.

To search for clients on the local network:

1. Select a scanner at the left of the Remote Desktop window.
2. Select Local Network.
   All responding clients are listed in the Remote Desktop window.
3. Select the desired computers.
4. Drag the selected computers to the Master List.
5 Authenticate by providing a login name and password for an ARD administrator.
The computer is now in your Master List.

**Finding Clients by Searching a Network Range**
To locate computers by network range, you provide a beginning and ending IP address to scan, and Apple Remote Desktop queries each IP address between them in sequence, asking if the computer is a client computer. This method is best when searching for clients outside the local subnet, but on the local area network.

**To search a range of network addresses:**
1 Select a scanner at the left of the Remote Desktop window.
2 Select Network Range.
3 Enter the beginning and ending IP address.
4 Click the Scan button.
   All responding clients are listed in the Remote Desktop window.
5 Select the desired computers.
6 Drag the selected computers to the Master List.
7 Authenticate by providing a login name and password for an ARD enabled administrator.
The computer is now in your Master List.

**Finding Clients by Network Address**
If you know the exact IP address or fully qualified domain name of a computer, you can use that IP address or domain name to add it to your Master List.

**To search for a specific address:**
1 Select a scanner at the left of the Remote Desktop window.
2 Select Network Address.
3 Enter the IP address or fully qualified domain name in the Address field.
4 Click the Scan button.
   If the client successfully responds, it is listed in the Remote Desktop window.
5 Select the desired computers.
6 Drag the selected computers to the Master List.
7 Authenticate by providing a login name and password for an ARD administrator.
The computer is now in your Master List.
Finding Clients by File Import
You can import a list of computers into Apple Remote Desktop by importing a file listing the computers' IP addresses. The list can be in any file format (text, spreadsheet, word processor) and must contain either IP addresses or fully qualified domain names (such as foo.example.com).

To import a list of computers from a file:
1 Select a scanner at the left of the Remote Desktop window.
2 Select File Import.
3 Browse for the file by clicking the Browse button, or drag a file into the window.
   Alternatively, you can enter the file's pathname in the File field.
4 Click the Scan button.
   All responding clients are listed in the Remote Desktop window.
5 Select the desired computers.
6 Drag the selected computers to the Master List.
7 Authenticate by providing a login name and password for an ARD administrator.
   The computer is now in your Master List.

Making a New Scanner
You may want several scanners to search for specific address ranges or to do other types of searches, you can make and save your own scanner so you can quickly do the search at any time.

You can rename scanners to make them easy to identify.

To make a custom search list:
1 Choose File > New Scanner.
2 Rename the newly created scanner.
3 Select the new scanner icon.
4 Choose a search type from the pop-up menu to the right.
5 Customize the search by entering the specific parameters for the search (such as an IP address range, or file location).

You can find out how to customize the search in the following sections:
- Finding Clients by Searching the Local Network on page 54
- Finding Clients by Searching a Network Range on page 55
- Finding Clients by Network Address on page 55
- Finding Clients by File Import on page 56
Click the Scan button.
All responding clients are listed in the Remote Desktop window.
Select your scanner icon and click the Scan button whenever you want to run the search.

Making and Managing Lists
You use lists to organize and perform management tasks on client computers. Apple Remote Desktop has several different kinds of lists. The following section describes the kinds of lists, and explains how to create lists and use them for client management.

About ARD Computer Lists
Apple Remote Desktop displays computers in lists in the main section of the Remote Desktop window. The default computer list is called Master List; this is a full list of all possible clients that you have located and authenticated to. You can create other lists to group the computers on your network in any way you wish.

Computer lists have the following capabilities:
• You can create as many lists as you want.
• Each list can have up to 1000 computers in it.
• The Master List can have up to the number of computers your license allows.
• Computers can appear in more than one list.
• Lists can be made in any grouping you can imagine: geographic, functional, hardware configuration, even color.

Creating an ARD Computer List
You can make more specific, targeted lists of computers from your Master List. The easiest way to make a new list is to use computers already in the Master List. You can also create blank lists and add computers to them later.

To create an ARD computer list:
1 Select the Master List icon in the main Remote Desktop window.
2 Select the computers you want to add to the new list.
3 Choose File > New List From Selection.
4 Name the computer list.

Alternatively, you can choose File > New List to create a blank list and drag computers from the Master List or scanner search results to the blank list.

Deleting ARD Lists
You can delete Apple Remote Desktop computer lists and additional scanner lists that you created. You cannot delete the Master List, the last scanner, or the Saved Tasks list.

To delete a list:
• Select the list and press the Delete key.
Using the Task History Area
The task history area is in the bottom half of the Remote Desktop window (see Task History Area on page 46). Every time you execute a task (generating a report, copying a file, restarting a computer), the task name, result, and time you execute it is listed in the task history area. You can resize the task history area, or even close it off entirely.

You can select a task in the task history area to see information about it. You can also view a more detailed description of the task, as well as the computers involved with it. If a task is still in progress, you can stop it, or edit the computers involved with it and run it again.

Viewing Task Feedback
After a task is completed (observing a computer, copying a file, restarting a computer), the task name, result, and time you run it are stored for review. The task feedback window gives a detailed account of the task, and reports success or failure for each participating client computer.

To view the task feedback window:
• Double-click the task in the task history area.

Using Task Feedback
You can use the task feedback window to:
• Retry a task on selected computers
• Duplicate a task
• Cancel a task in progress

To use the task feedback window:
1 Double-click the task in the task history area.
2 Select the client computers you want to perform the task on.
3 Choose a function from the menu.

Installing Software Using ARD
There are several methods you can use to install software with Apple Remote Desktop. The following section describes how to install software using installer packages or metapackages, using the copy command in ARD, using installers made by other software companies, or using NetBoot or Network Install.

Warning: Distributing copyrighted software without the appropriate license agreement is a violation of copyright law.
Installing by Package (pkg) and Metapackage (mpkg)

You can install new software automatically and without user intervention by copying installer packages (.pkg or .mpkg files) to one or more remote clients using Mac OS X version 10.2 or later. Apple Remote Desktop copies the package to the computers you choose, runs the installer with no visible window or user interaction required, and then erases the installer files upon completion.

You can install multiple packages in succession. When you execute installation of multiple packages, ARD copies over a package, installs it, and then copies and installs the next package until finished.

It is not possible to stop the installation of a package. Once the installation starts, it will complete (assuming no errors occur on the client). However, you can click the Stop button to stop any additional packages (in a multiple-package install) from being copied over and installed.

Alternatively, an administrator with access to Apple Developer Tools can use the PackageMaker application to create a “metapackage” that contains several installers to be run in sequence. In addition to creating metapackages, you can also use PackageMaker to create packages for custom software that your organization may have developed. More information about making and using packages and metapackages is available through the Apple Developer Connection website:


To copy and install software using a .pkg file:

1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Install Packages.
4 Select a .pkg or .mpkg file to install.
5 Click Install.

During installation, a progress bar appears on the administrator’s screen. No progress bars appear on the client computer. The package copied is deleted from the client computer if an error occurs during installation. However, a failed installation may leave behind other files created by the installer.

Note: Client computers are not restarted automatically after an installation is complete. If restarting is necessary, use the Restart command to restart selected computers after using the Install Packages command.
Installing by Using the Copy Items Command

Many applications can be installed simply by copying the application or its folder to the client computer. Consult the application’s documentation to verify that you can simply copy the application to the hard disk to install it.

To install software by copying:
1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
3. Choose Manage > Copy Items.
4. Add software to the copy list.
   - For more information, see "Copying Files" on page 63.
   - Repeat this step, until all the software you want to copy is in the list.
5. Select a copy destination.
   - There are several preset destinations available in the destination pop-up menu, including the Applications folder. If you do not see the destination you want, you can enter a file path.
6. Click Copy.
   - The software is copied to the indicated destination. If the copy is unsuccessful, an error message appears in the active task viewer.

Using Installers From Other Companies

The Install Packages command only works with installers that use the .pkg or .mpkg file formats, and some applications can’t be installed by simply copying the application to the hard disk. To install software using installers with different file formats, you use a combination of administrative tasks.

To install software with third-party installers:
1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
3. Choose Manage > Copy Items.
4. Add the software installer to the copy list.
   - For more information, see "Copying Files" on page 63.
5. Select a copy destination.
6. Click Copy.
   - The software is copied to the indicated destination. If the copy is unsuccessful, an error message appears in the task feedback window.
7. Select Open After Copy.
8. Select a computer that received the copy of the installer.
9 Choose Interact > Control.

10 Control the screen of the selected computer and complete the installation process interactively.

**Using ARD With Mac OS X Server’s NetBoot and Network Install**

You can’t install Mac OS X on a client using only Apple Remote Desktop. However, when used in conjunction with Mac OS X Server’s NetBoot and Network Install features, ARD can provide valuable, time-saving assistance. You can use it to set the startup volumes remotely, and then further customize the computers after installation.

The following example procedures assume a familiarity with Mac OS X Server’s features, Network Image Utility, and the command-line operations in Mac OS X.

**To install system software using ARD with Network Install:**

1 Install and configure Mac OS X on a client computer.

   The other client computers will be based on this computer. The client should be configured with all your desired software, your desired sharing preferences set, an ARD login, and ARD administrative privileges. It should have DHCP enabled as its network addressing method. See [Setting Up Client Computers With Mac OS X 10.3 Installed](page 32) for more information.

2 Use Disk Utility to create a disk image of the client computer’s hard disk.

   You cannot create a disk image from the startup disk. You need to start up from some other partition before creating a disk image of the computer’s hard disk.

3 Use Network Image Utility to create a Network Install image for Mac OS X Server using the disk image.

   You should have the following parameters set:
   • Install automatically on the volume named “Macintosh HD”.
   • Don’t prompt.
   • The NetBoot image should be named Macintosh HD.

4 Use ARD to copy the AppleScript shown below to the client computers and then run it. It will set the hard disk name to the name “Macintosh HD” for use with the NetBoot image. If you have created a volume named “CloneMe,” this script will name that volume “Macintosh HD.”

```
tell application "Finder"
   if (exists {disk "Macintosh HD"}) then
      -- Nothing
   else if (exists {disks whose name contains "CloneMe"}) then
      set the name of first disk whose name contains "CloneMe" to "Macintosh HD"
   else
      set the name of disk 1 to "Macintosh HD"
   end if
end tell
```
5 Use ARD to set the startup disk of your client computers to the Network Install image.
6 Once the clients have started up from the local hard disk again, use ARD to configure and customize the client computers as desired.

Upgrading Software
Upgrading software is similar to installing software. However, the method of upgrading software depends on the original method of installation. As a general rule, upgrades should not be done while users have their applications open. Make sure the software to be upgraded is not running.

**Warning:** Distributing copyrighted software without the appropriate license agreement is a violation of copyright law.

Upgrading consists of three main tasks:
- Finding out if a piece needs updating
- Removing the outdated version
- Installing the new version

To upgrade software on client computers:
1. Run a Software Version report to determine what version of the software client computers have.
   See "Generating a Software Version Report" on page 68 to learn how to run the report.
2. Remove the outdated version of the software.
   If the software was originally installed using a package or metapackage, it should be removed automatically when you install the new version.
   If the software was originally installed using the Copy Items command, you can delete the outdated version, or simply replace the old version with the new version when you install the new version.
   If the software was originally installed using another company’s installer application, you may need to use an uninstaller before installing the new version. Consult the software’s manual for instructions for removing its software. If an uninstaller application is necessary, you can copy it to each of the ARD client computers and run it remotely.
3. Use the appropriate installation method to install the new version of the updated software. For more information, see:
   - "Installing by Package (pkg) and Metapackage (mpkg)" on page 59
   - "Installing by Using the Copy Items Command" on page 60
   - "Using Installers From Other Companies" on page 60

Warning: Distributing copyrighted software without the appropriate license agreement is a violation of copyright law.
Copying Files
Apple Remote Desktop makes it easy to update items (other than the system software) on one or more client computers.

Copying files works fastest with a smaller number of files. For example, ten files that are 10 KB each will generally take longer than one file that is 100 KB. Consider copying a single file archive (like a .zip or .sit file) to remote computers for faster copying. Remember that Mac OS X applications are bundles of many smaller files. Although the application you want to copy looks like a single file in the Finder, it may contain dozens, or even hundreds of smaller files.

Copied files are not encrypted. If you have sensitive data being transferred across an unsecured network (like the Internet), it is recommended you use a Virtual Private Network (VPN) to encrypt the network traffic. Alternatively, you could encrypt a file archive before copying it. The encrypted archive itself could be intercepted, but it would be unreadable.

If a client computer is asleep when you attempt to copy items, ARD will try to wake the client. If it can't wake the client and the copy does not proceed, you should use ARD to wake the target computer, and then attempt the copy again.

Copying From Administrator to Client
Using Apple Remote Desktop, you can copy items to any number of client computers simultaneously.
To copy items to clients:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Copy Items.
4 Add software to the copy list.
   Click the Add button to browse local hard disks for items to copy, or drag software to the window.
   If you want to remove an item from the copy list, select the item then click Remove.
   Repeat this step, until all the software you want to copy is in the list.
5 Select a copy destination.
   There are several preset destinations available in the destination pop-up menu, including the Applications folder. If you do not see the destination you want, you can enter a file path for the copy destination.
6 If you want the copied items to open after being copied, select Open After Copying.
   If you select this option, files will open the parent application that created them.
7 Choose what to do if an item exists.
8 To confirm which computers you’ve selected, click View Target Computers.
   A drawer opens listing the computers that will receive this command.
9 If you want to schedule this event for another time, or set it to repeat, click the Schedule button.
   See [Scheduled tasks on page 84](#) for more information about scheduling events.
10 Click Copy.
   The software is copied to the indicated destination. If the copy is unsuccessful, an error message appears in the task feedback window.

Copying Using Drag and Drop
Using Apple Remote Desktop, you can copy items by dragging them between Finder windows on your administrator computer, the Remote Desktop window, and report windows. For example, you can drag an item from a Finder window to a selected computer in the Remote Desktop window. Alternatively, you can drag from a Software Report window to another computer in an ARD computer list.

You can use this feature to collect needed files from remote computers, or distribute files between remote computers.

To copy items from the Finder to a client:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Switch to the Finder.
4 Locate the item you want to copy in the Finder.
5 Drag the item you want to copy from the Finder to the selected clients in the Remote Desktop window.
6 If you want the copied items to open after being copied, select Open After Copying. If you select this option, files will open in the application that created them.
7 Choose what to do if an item exists.
8 Click Copy.

**Restoring Items From a Master Copy**

Your client computers can restore non-system software from a master copy. This is helpful if you want to make sure each client computer has the same software. You can automate the software restore process by using the instructions for in "Automating Functions" on page 84.

You may want to start by creating a disk image that contains the Mac OS X applications and items you want to copy. Alternatively, you can copy files from any local disk, such as a hard disk, CD, disk partition, or other disk.

The Copy Items command does not copy system software that is hidden (that is, not visible in the Finder). It can copy the Applications folder, Library folder, and Users folder, as well as any folders at the root of the hard disk that were created by the computer’s administrator user.

**Important:** You cannot use the Copy Items feature to copy Mac OS X system software to client computers.

**To restore files using the Copy Items command:**
1 Make a master copy of the volume that has the files to be restored.
   You can use any volume, such as a spare hard disk, a CD, or a mounted disk image file (.dmg).
2 Mount the master copy volume on the administrator computer.
   Master copy volumes must be local volumes, and not mounted from over a network.
3 Open Remote Desktop.
4 Select a computer list.
5 Select one or more computers in the Remote Desktop window.
6 Choose Manage > Copy Items.
7 To confirm which computers you’ve selected, click View Target Computers.
   A drawer opens listing the computers to receive this command.
8 Add the master copy volume to the Copy Items list.
If you want to schedule this event for another time, or set it to repeat, click the Schedule button. See "Scheduled Tasks" on page 86 for more information about scheduling events.

Click Copy.

If a message asks if you want to replace some items, click Replace.

Creating Reports
Apple Remote Desktop allows you to query client computers for many kinds of information, from installed software to network speed and reliability. Creating reports gives you valuable information about the client computers. Reports also serve as valuable shortcuts when you’re copying files and organizing computer lists.

Understanding Saved and New Report Data
There are two sources of data about the client computers that ARD uses when searching for report information: saved and new.

With a new data search, the Remote Desktop application queries a client directly, and waits for the client computer to respond with the desired information. A new data search gets the most recent information, but takes longer since the client computer has to gather all the data and send it over the network to the waiting administrator computer.
With a saved data search, the application queries ARD's internal database of collected system information (such as hardware information and system settings), file information (including installed applications and versions, and software names), or both. You determine how often the data is collected, and what type of data is stored. See “Setting the Data Reporting Policy” on page 68.

The database is a PostgreSQL database located at /var/db/RemoteManagement/RMDB/ and can be accessed using other tools besides ARD. To find out more about the database schema, see “PostgreSQL Schema Sample” on page 114. You can determine whether the database is located on the administrator computer or on a separate server.

Reports run from saved data searches are fast, and trade currency for speed. Saved data searches are enabled by default. However, for any report, you can specify if you want to search saved data or new data. For added flexibility, you can set a report to run on saved data only if the saved data is as recent as you want.

**Finding Files, Folders, and Applications**

Apple Remote Desktop allows you to search the contents of client computer hard disks for specific files, folders, or applications. Additionally, it can compare the results of such searches to the items on the administrator computer. These searches can compare software versions, fonts, applications, or installed packages.

**Generating a File Search Report**

The File Search report allows you to find up to 32,000 total items on selected computers. The items can be files, folders, or applications, and can only be items accessible (or visible) to the Finder.

The search parameters include:

- Name
- Parent Path
- Full Path
- Extension
- Size
- Kind
- Date Created
- Date Modified
- Version Number
- Version String
- Owner
- Group
- Lock Status
The search parameters for Apple Remote Desktop are slightly different from those used by the Finder’s Find command. For example, ARD does not search by visibility or label. The report display can be customized as well. See page 73 for more information.

To search for software items:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Report &gt; File Search.
4 Choose the desired search parameter from the pop-up menu and enter a search term.
5 If you want to customize the report display, do so now.
6 To search using new data, select Collect New Data For Report; to search using saved data only, deselect Collect New Data For Report.
7 Click Search.

The newly generated report window appears.

Comparing Software
Apple Remote Desktop has several specialized reports for comparing software on client computers with software on the administrator’s computer. These are run from a computer with the desired fonts, or with the correct version of software installed.

Generating a Software Version Report
The Software Version report compares application versions on client computers to application versions on the administrator computer. You can select up to 10 applications to compare. Command-line tools and unbundled Java (jar) applications do not report their version.

To generate a Software Version report:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Report &gt; Software Version Report.
4 Select the software you want to compare from the application list.

You can select up to 10 applications.
If the application you want doesn’t appear in the list, click the Add button (+) to browse for the application.
5 To search using new data, select Collect New Data For Report; to search using saved data only, deselect Collect New Data For Report.

If you want to search using new data only if the saved data is too old, select If Current Data Older Than, and enter the desired amount of time.

6 Click Generate Report.

The newly generated report window appears.

**Generating a Software Difference Report**

The Software Difference report compares the applications, fonts, and installed packages of the selected client computers with those on the administrator computer. The resulting report lists the items compared, their version, location, and whether or not they were found on the selected client computers.

The Software Difference report can compare all executable Mac OS X and Classic applications. Unbundled Java (.jar) applications and command-line utilities are not included in the report. The report can compare all the fonts in the /System/Library/Fonts and /Library/Fonts directories, as well as the font directory for the currently logged in user. Comparing installed packages returns a list of all package receipts in the /Library/Receipts directory.

You can use this report to find out if your clients have the applications or fonts they need. Comparing differences in installed packages can help you troubleshoot software conflicts, or keep your client computers up to date.

**To generate a Software Difference report:**

1 Select a computer list.

2 Select one or more computers in the Remote Desktop window.


4 Select the software type you want to compare.

   Selecting Applications compares all executable applications.

   Selecting Fonts compares all fonts in the /Library/Fonts directory, /System/Library/Fonts, and user font directories.

   Selecting Installed Packages compares all package receipts in the /Library/Receipts directory.

5 To search using new data, select Collect New Data For Report; to search using saved data only, deselect Collect New Data For Report.

   If you want to search using new data only if the saved data is too old, select If Current Data Older Than, and enter the desired amount of time.

6 Click Generate Report.

   The newly generated report window appears.
Auditing Hardware
You can get a report about the hardware of any client computer. Hardware information can be accessed using a number of different reports. Although some basic hardware information can be found in the System Overview report, several more focused hardware reports provide more detailed information.

Storage
The Storage report collects information about the client computer’s internal hard disks. It can get information about the hardware itself, the volumes present on the disk, file system information, and journaling information for the disk.

For a complete listing of Storage report options, see Report Field Definitions Reference on page 107.

Basic information about hard disk volumes and size can also be found in the System Overview report, in the Storage options.

To generate a Storage report:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Report > Storage.
4 Select the hard disk information desired.
5 To search using new data, select Collect New Data For Report; to search using saved data only, deselect Collect New Data For Report.
   If you want to search using new data only if the saved data is too old, select If Current Data Older Than, and enter the desired amount of time.
6 Click Generate Report.
   The newly generated report window appears.

FireWire Devices
The FireWire Devices report gets information on FireWire devices connected to the client computer. It can get the following information from a device:
- Manufacturer
- Model
- Device Speed
- Software Version
- Firmware Version

For more information about FireWire Devices report options, see Report Field Definitions Reference on page 107.

The number of attached FireWire devices can also be found in the System Overview report, in the Devices options.
To generate a FireWire Devices report:
1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
4. Select the FireWire information desired.
5. To search using new data, select Collect New Data For Report; to search using saved data only, deselect Collect New Data For Report.
   If you want to search using new data only if the saved data is too old, select If Current Data Older Than, and enter the desired amount of time.
6. Click Get Report.
   The newly generated report window appears.

USB Devices
The USB Devices report gets information on Universal Serial Bus devices connected to the client computer. It can get the following information from a device:
• Product Name and ID
• Vendor Name and ID
• Device Speed
• Bus Power Amps

For more information about the USB Devices report options, see [Report Field Definitions Reference](#) on page 107.

Basic information about attached USB devices can also be found in the System Overview report, in the Devices options.

To generate a USB Devices report:
1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
4. Select the USB device information desired.
   For more information about the USB Devices report options, see [Report Field Definitions Reference](#) on page 107.
5. To search using new data, select Collect New Data For Report; to search using saved data only, deselect Collect New Data For Report.
   If you want to search using new data only if the saved data is too old, select If Current Data Older Than, and enter the desired amount of time.
6. Click Get Report.
   The newly generated report window appears.
Network Interfaces

The Network Interfaces report gets information for all network interfaces, including inactive interfaces. It also gets detailed network, output, and Ethernet statistics from client computers.

The Network Interfaces report can be used to find network errors, or faulty network equipment, troubleshoot network performance, and query the network settings of the client computers.

All detailed statistics are refreshed when the client restarts, and address information may change if your client uses DHCP to get a network address.

For a complete listing of Network Interfaces report options, see Report Field Definitions Reference on page 107.

Basic information about network settings can also be found in the System Overview report, in the Network and AirPort options.

To generate a Network Interfaces report:

1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
4. Select the interface information desired.
5. To search using new data, select Collect New Data For Report; to search using saved data only, deselect Collect New Data For Report.
   If you want to search using new data only if the saved data is too old, select If Current Data Older Than, and enter the desired amount of time.
6. Click Generate Report.

   The newly generated report window appears.

Memory

The Memory report gets specific information about the installed memory (RAM) in a client computer. In addition to reporting how much memory the client has, it shows information about each memory module, including the module's:

- Slot location
- Size, type, and speed

Memory reports can be used for managing computer resources, hardware troubleshooting, or deciding which client computer can handle a memory-intensive application or task.

For more information about the Memory report options, see Report Field Definitions Reference on page 107.
Basic information about system memory can also be found in the System Overview report, in the Computer options.

To generate a Memory report:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Report > Memory.
4 Select the module information desired.
5 To search using new data, select Collect New Data For Report; to search using saved data only, deselect Collect New Data For Report.
   If you want to search using new data only if the saved data is too old, select If Current Data Older Than, and enter the desired amount of time.
6 Click Get Report.
   The newly generated report window appears.

PCI Cards
The PCI Cards report gets specific information about the PCI cards installed in a client computer. It shows information about each PCI card, including each card’s:
• Slot name
• Card name, type, memory, speed, and revision (version)
• Vendor’s and device’s IDs
• ROM revision

For more information about the PCI Cards report options, see Report Field Definitions Reference on page 107.

Basic information about a client’s PCI cards can also be found in the System Overview report, in the Computer options.

To generate a PCI Cards report:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Report > PCI Cards.
4 Select the PCI card information desired.
5 To search using new data, select Collect New Data For Report; to search using saved data only, deselect Collect New Data For Report.
   If you want to search using new data only if the saved data is too old, select If Current Data Older Than, and enter the desired amount of time.
6 Click Generate Report.
   The newly generated report window appears.
Testing Network Responsiveness

Apple Remote Desktop can test network responsiveness between your administrator computer and client computers. It sends network packets to the clients and reports the time taken to receive confirmation from the clients.

You can choose how many network packets to send, how often they are sent, and how long the administrator computer waits for a reply before listing a packet as lost.

To generate a Network Test report:

1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
4. Select the options you want.
   - Choose the number of packets sent from the Packets pop-up menu.
   - Choose how often to send the send packets from the Interval pop-up menu.
   - Choose how long to wait before reporting a packet as lost from the Time-Out pop-up menu.
5. Click Get Report.

The newly generated report window appears.

Evaluating the Network Test Report

You can use the Network Test report to diagnose whether task failures in Apple Remote Desktop are due to network congestion or some other factor. You may, for example, find that a Copy Items task is failing on a particular subnet, due to network congestion on that subnet. Here are some suggestions for evaluating your network performance based on this report:

- The number of routers between your computer and another computer can affect the time the packets take to return. When you evaluate the times for a computer, you should compare them to the times for a computer in the same area of the network or with the same number of intervening routers.
- If the maximum time for a packet to return from a computer is significantly greater than the times for other computers in the same area of the network, there may be a problem with the computer.
- If a single computer has a large number of lost packets, there may be a problem with the network connection to that computer.
- If several computers in the same area of the network have a large number of lost packets, there may be a network connection problem or a problem with an intervening router or bridge.
Changing Report Layout

You can customize report layouts for your own purposes. By default, reports include a column for each information type you selected before running the report, in the order presented in the report dialog. The columns in the report are initially sorted by computer name.

You can resize or rearrange the columns of a report as well as sort the rows by column.

Additionally, in the File Search report, you can choose what information is displayed about a found item. By default, the item name, kind, parent path, actual size, and date modified are displayed.

To change what information is displayed:

1. In the File Search report window, select or deselect each report column as desired.

<table>
<thead>
<tr>
<th>Report column</th>
<th>If checked, will show...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The item name</td>
</tr>
<tr>
<td>Parent Path</td>
<td>The path to the folder that the item is in</td>
</tr>
<tr>
<td>Full Path</td>
<td>The full file path</td>
</tr>
<tr>
<td>Extension</td>
<td>The file extension indicating the file type (.app, .zip, .jpg)</td>
</tr>
<tr>
<td>Date Modified</td>
<td>The last date and time the file was changed and saved</td>
</tr>
<tr>
<td>Date Created</td>
<td>The date and time the file was created</td>
</tr>
<tr>
<td>Actual size</td>
<td>Actual file size in KB or MB</td>
</tr>
<tr>
<td>Size on Disk</td>
<td>Amount of disk space used by the file in KB</td>
</tr>
<tr>
<td>Kind</td>
<td>File, folder, or application</td>
</tr>
<tr>
<td>Invisible</td>
<td>A checkmark indicating whether it is visible in the Finder</td>
</tr>
<tr>
<td>Version Number</td>
<td>If an application, the version reported</td>
</tr>
<tr>
<td>Version String</td>
<td>If an application, the version reported</td>
</tr>
<tr>
<td>Owner</td>
<td>The item's owner's short name</td>
</tr>
</tbody>
</table>


<table>
<thead>
<tr>
<th>Report column</th>
<th>If checked, will show...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group</td>
<td>The item's group's name</td>
</tr>
<tr>
<td>Permissions</td>
<td>The item's UNIX permissions (for example, -rw-r--r--)</td>
</tr>
<tr>
<td>Locked</td>
<td>A checkmark indicating whether it is a locked file</td>
</tr>
</tbody>
</table>

2 After making your selections, click Generate Report as usual.

When the report window appears, you can rearrange the columns or sort by a different column.

Exporting Report Information
You can export reports into a comma-delimited or tab-delimited text file. All the columns of information in the report window are included, and the report rows are exported in the order they’re sorted at the time of export.

Exported reports can be put into databases, spreadsheets, or word processors for further analysis or organization, or to be sent to another administrator. You could even use certain reports as input files for network scanners for Remote Desktop.

To export a report:
1 Generate any report, and bring the report window to the front.
2 If desired, sort the report rows by selecting a new column to sort by.
3 If you do not want to export the entire report, select the rows to be exported.
4 Choose File > Export Window.
5 Name the file, and choose a location to save to.
6 Select a Text Encoding.
   • Western (Mac OS Roman): Best choice if the report information uses the Roman alphabet, and the exported document will be opened in an application or on an operating system that does not support Unicode text encoding, like some installations of Mac OS 9.
   • Unicode (UTF-8): Best choice if the exported file will be opened on Mac OS X and contains no Asian text characters, like Chinese or Japanese.
   • Unicode (UTF-16): Best choice if the report contains Asian language text characters.
7 Select a Field Separator.
   • Tab: Inserts a Tab character between column values.
   • Comma: Inserts a comma between column values.
8 If you have selected only some rows of the report, and want to export only the selected rows, select Save Selection Only.
9 Click Save.
Using Report Windows to Work With Computers
After you've created a report, you can use it to select computers and then do any of the following:

- Add computers to ARD computer lists.
  Drag any row from a report window to a computer list in the main Remote Desktop window. This adds the computer in that row to the computer list.
- Create new computer lists.
  Select computers in the report window and click the New List button.
- Generate other reports.
  Select any number of rows in a report window; then choose another report from the Report menu. The new report will be generated on the computers in the selected rows.
- Initiate any management task.
  Select any row in a report window; then choose a management task from the Manage menu. This has the same effect as selecting the computers in an ARD computer list.

Additionally, you can copy items to computers selected in the report window by dragging items from the Finder to the selected computer or computers. See "Installing by Using the Copy Items Command" on page 64 for more information.

- Interact with users.
  Select any row in a report window; then choose a task from the Interact menu. This has the same effect as selecting the computers in a computer list.
- Delete an item from a computer.
  Select an item in any software report window and click the Delete button.

Maintaining Systems
Apple Remote Desktop provides easy and powerful tools to maintain client computers, including deleting files, emptying the Trash, and setting computer startup options.

Deleting Items
If you delete a file on a client computer, it is moved to the client's Trash.

To delete an item from a client:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Report > File Search.
4 Find the software you want to delete using the File Search report.
   For more information, see "Finding Files, Folders, and Applications" on page 67.
5 Select the item or items you want to delete in the File Search report window.
6 Click Delete in the report window. Alternatively, drag the items to the Trash on your desktop.

7 Click OK.

**Emptying the Trash**

Apple Remote Desktop allows you to empty the Trash on clients to free up disk space. To find out how much free disk space is on a computer, create a System Overview or Storage report using the Report menu.

If a report shows files that shouldn’t be on the computer, you can delete those files directly from the report window. See “Deleting Items” on page 77.

As a part of routine maintenance for computers, you can free disk space by emptying the Trash. Emptying the Trash completely removes from the computer any items you’ve previously deleted on the client. You can use the System Overview report to see how much disk space you can recover by emptying the Trash.

**To empty the Trash:**
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Empty Trash.
4 Click Empty.

**Setting the Startup Disk**

Apple Remote Desktop can set the startup disk on any client computer. You can choose between a volume on a local hard disk, or any available NetBoot volume.

The startup disk must have a valid system installed on it. To set the startup volume for multiple computers at once, the local volume name must be the same for all computers.

Alternatively, you can set the startup disk to be a NetBoot volume provided by Mac OS X Server. This allows you to start up a number of clients from a NetBoot server, allowing for automated network installs. For some ideas on how to use this command with NetBoot and Network Install, see “Using ARD With Mac OS X Server’s NetBoot and Network Install” on page 61.

**To set the startup disk:**
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Set Startup Disk.
The list that appears shows the client's local hard disk, a custom NetBoot server item, and a listing of all available NetBoot and Network Install servers available on the local network subnet.

4 Choose the client's local hard disk or a NetBoot server volume.

5 If you want to choose a custom NetBoot server volume, enter the server IP address or fully qualified domain name, and the NetBoot volume name.

6 If desired, select Restart When Done.
   If selected, the client computer will restart after having its startup volume set. You need to have Restart privileges to use this option.

7 Click Set.

**Renaming Computers**

Apple Remote Desktop can set the name that a client computer uses for file sharing. You can rename multiple computers with the same name followed by a number (such as Computer1, Computer2, and so on). This is especially useful for differentiating client computers after a clean system install.

*Note:* The Rename Computer feature does not change the Bonjour name or the DNS name of a client computer.

**To rename a computer:**

1 Select a computer list.

2 Select one or more computers in the Remote Desktop window.

3 Choose Manage > Rename Computer.

4 Enter the new computer name.

5 If desired, select Append a Unique Number For Each Computer.
   Selecting this option appends a unique number to the end of the filename. For example, if you rename three computers “Computer,” the computers will be named “Computer1,” “Computer2,” and “Computer3.”

6 Click Rename.

**Managing Computers**

Using Apple Remote Desktop, you can control multiple client computers simultaneously, issuing commands that are found in Mac OS X's Apple menu, as well as other commands.
Opening Files and Folders

Apple Remote Desktop can open existing items (files, folders, and applications) on client computers. The item to open must be on the administrator computer, in addition to being on the client computers, and must have the same name, type, size, permissions, and file creation date as the item on the administrator computer.

The Open Item command opens files in the application used to create them, if it exists on the client computer, or in the application assigned to open files with that file's extension. Folders open in the Finder. Applications are opened, or brought to the front, if already open.

To open an item:
1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
3. Choose Manage > Open Item.
4. Click (+) and browse for the item on the administrator computer.
   Alternatively, drag the item from the administrator computer's Finder to the Open Item dialog.
5. Click OK when the item is selected.
   The Open Item dialog shows the icon and name of the item to open.
6. Click Open.

Opening Applications

Apple Remote Desktop can open applications on client computers. The application to open must be on the administrator computer, in addition to being on client computers. If the application is already open, the Open Application command brings it to the front. You can open both Mac OS X and Classic applications with this command.

The application on the administrator computer must have the same name, type, and permissions as the one to be opened on the client computer.

To open an application:
1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
3. Choose Manage > Open Application.
   The Open Application dialog shows the applications installed and found in the Applications folder at the top level of the hard disk, and the administrator's Applications folder (~/Applications).
4 Select the application or click Browse to find the desired application on the administrator computer.

Alternatively, drag the item from the administrator computer’s Finder to the Open Application dialog.

The Open Application dialog shows the icon and name of the application to open.

5 Click Open.

**Putting a Computer to Sleep**

Apple Remote Desktop can put client computers to sleep. This has the same result as choosing the Sleep command on the client: the display sleeps, the hard disks spin down, and the computer's central processor and network interface are put in a low-power mode.

Although you can put computers to sleep via AirPort, you will not be able to wake them using ARD.

**To put a computer to sleep:**

1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Sleep.
4 Click Sleep.

**Waking Up a Computer**

Apple Remote Desktop can wake up computers that have gone to sleep or been put to sleep with ARD. To wake a computer using ARD, the computer’s networking hardware must support waking via network packet (wakeonlan), and the computer must have “Wake For Administrative Access” enabled in the Wake Options of Energy Saver preferences.

You cannot wake up computers connected to the network via AirPort or computers not located on your local subnet.

**To wake a computer:**

1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Wake.
4 Click Wake.
Locking a Computer Screen
Apple Remote Desktop can lock a computer screen. When you lock a computer screen, no one can see the desktop or use the mouse and keyboard on that computer. By default, ARD displays a picture of a padlock on locked screens, but you can display a custom picture.

You can continue to work with computers using Remote Desktop after you’ve locked their screens. However, the screen becomes unlocked if you use the Observe, Control, or Share commands.

To lock a computer screen:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Interact > Lock Screen.
4 Enter a message to be displayed on the locked screen, if desired.
5 Click Lock Screen.

The screen goes black, except for the administrator’s name and any message text.

Displaying a Custom Picture on a Locked Screen
You can display a picture of your choice on the client screen while it is locked by Apple Remote Desktop. When creating images, make sure the image size will fit on the client computer’s screen. For example, if you have clients with 800 x 600 screens, a picture that is 1024 x 768 will be scaled down to fit the screen.

To create a custom locked screen picture:
1 Create a picture using a graphics program, such as AppleWorks.
2 Save the picture in PICT, TIFF, GIF, JPEG, or any other QuickTime-compatible static image format.
   QuickTime-compatible movies or QuickTime VR objects cannot be used.
3 Name the picture “Lock Screen Picture”.
4 Copy the “Lock Screen Picture” file to /Library/Preferences/ on the client computer.

Unlocking a Computer Screen
You must use Apple Remote Desktop to unlock any computer screen locked by ARD. When you unlock a computer screen, you restore the desktop and use of the mouse and keyboard on that computer.

To unlock a computer screen:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Interact > Unlock Screen.
4 Click Unlock Screen.

Logging Out the Current User
Apple Remote Desktop can log out the current user on a client computer. Other users, besides the current active user, who are logged in using Fast User Switching are not logged out using this command. Using this command returns the client computer to the login window.

To log out a user:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Logout Current User.
4 Select the type of logout.
   You can allow users to save files or cancel the logout, or you can force an immediate logout, which will cause the users to lose unsaved changes to any open files.
5 Click Logout User.

Restarting a Computer
Apple Remote Desktop can restart a client computer. This has the same result as choosing the Restart command from the client computer’s Apple menu.

This feature is especially useful when used with the Install Packages command. Install Packages doesn’t restart the computer, even if the package requires it. You must restart the computer using ARD after installing a package.

To restart a computer:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Restart.
4 Select the type of restart.
   You can allow users to save files or cancel the restart, or you can force an immediate restart, which will cause the users to lose unsaved changes to any open files.
5 Click Restart.


Shutting Down a Computer

Apple Remote Desktop can shut down a client computer. This has the same result as choosing the Shut Down command from the client computer’s Apple menu.

Note: If you shut down an ARD client, you cannot start it up using ARD.

This command is especially useful when used with Energy Saver preferences. You can set your client computers to start up every morning at a designated time, and use ARD to shut them down at night. The next morning, they will start up and be ready to administer.

To shut down a computer:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Shut Down.
4 Select the type of shutdown.
   You can choose to allow users to save files or cancel the shutdown, or you can force an immediate shutdown, which will cause the users to lose unsaved changes to any open files.
5 Click Shut Down.

Automating Functions

You can automate any command or function in Apple Remote Desktop. Additionally, ARD gives scripting-savvy administrators tools (either UNIX or AppleScript) to help automate their client management.

Setting the Data Reporting Policy

To speed up reporting and allow reporting from offline clients, Apple Remote Desktop uses saved client system and file information. You can automate the collection of this information for reports by setting the data reporting policy. This schedule determines how often the client updates its system and file information for reports.

In accordance with the collection schedule you set, each client computer connects to a central reporting database, and uploads the information you designate. There are certain trade-offs to the frequency of these updates. If you require all the clients to update their information too often, you run the risk of added network traffic and slower client performance during updates. If you don’t require the clients to update often enough, the report data that you receive may be out of date. You should take care to balance your reporting needs and your network and client performance needs.
The collection policy includes two kinds of information: system information and file system information. System information includes all possible reported information for the following reports:

- System Overview
- Storage
- USB Devices
- FireWire Devices
- Network Interfaces
- Memory
- PCI Cards

The file system information includes all possible reported information for the following reports:

- File Search
- Software Version
- Software Difference

To set a client’s data reporting policy:

1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
3. Choose Manage > Set Reporting Policy.
4. Select On a Schedule.
   - To disable a client’s automatic data collection, select Only When Needed For A Report.
5. Choose the day or days the data collection should occur.
6. Set the time at which the collection occurs.
7. If desired, set the time interval each day between collections by selecting On Selected Days Repeat Every ____ Hours.
8. If desired, set the time interval between scheduled rebuilds if newer data exists by selecting Skip Rebuild If Data Is Newer Than ____ Hours.
   - This sets the minimum number of hours or minutes that can occur between data collections.
9. Choose System Data, File Data, or both.
10. Click Set.
Setting the Report Data Collection Location

To speed up reporting, Apple Remote Desktop uses a database of client system and file information. You can automate the collection of this data for reports, and determine where the database will reside. By default, the database is stored on the administrator’s own computer. Use these instructions to change the data collection location.

**Warning:** If you change the location of the report database from the one selected in the initial setup, you will need to reset the collection policies for the client computers. The database will not be moved, but will be regenerated at the next collection interval.

First, determine where the data will be located: on the administrator computer, or a remote computer. A remote computer that collects the data needs to be a licensed ARD administrator computer and have TCP and UDP ports 3283 and 5900 open to all of the reporting client computers. If you choose to use another ARD administrator computer’s database, you must configure it to allow data access to other ARD administrators.

If you choose to store the data locally, and have an unlimited client license, you can allow other ARD administrators to access the database on your computer by selecting the “Allow Remote Connections To Local Agent” option.

**To set the data collection location:**

1. Open Remote Desktop.
2. Choose Remote Desktop > Preferences.
3. Click Data Collection.
4. If you want to use the database on this administrator computer, select This Computer.
   - If you want to let other ARD administrators access the database on the local administrator computer, click Allow Others To Use This Computer To Collect Data For Reports.
5. If you want to use a database on another administrator computer, select Another Licensed Remote Desktop Computer.
   - Then, enter the IP address or fully qualified domain name of the other ARD administrator computer.
6. Close the window to save changes.

**Scheduled Tasks**

You can use Apple Remote Desktop to automate and schedule almost any task. For example, you can make sure a particular application or a specific set of fonts is always available on a client computer by setting ARD to copy applications and fonts to the client every night.
When you schedule an automated task, information about the scheduled task is saved on the administrator computer. At the appointed time, the client software on that computer activates and initiates the task. Remote Desktop must be open to perform a scheduled task.

<table>
<thead>
<tr>
<th>Button</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Schedule icon]</td>
<td>Any task with a Schedule button active can be scheduled.</td>
</tr>
<tr>
<td>![Schedule icon]</td>
<td>For tasks that have already been scheduled and have pending events, the Schedule button is slightly different.</td>
</tr>
</tbody>
</table>

### Setting Scheduled Tasks
Any task with the Schedule Task button active can be scheduled. Tasks that you have scheduled appear in the Saved Tasks list in the main Remote Desktop.

#### To schedule a task:

1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
3. Choose the task you want to schedule from the menu bar.
4. Configure the task as needed.
5. Before executing the task, click the Schedule button.
   - The scheduling dialog opens.
6. Choose whether you want the task to execute now, or at a specific time.
   - If you choose a specific time, enter the date and time.
   - Selecting "Run Now" rather than "At a Specified Time" turns off scheduling for that task.
7. If you want the task to repeat, click Repeating, then set the repeat interval.
8. Click OK.
9. Save the task.
Editing Scheduled Tasks
Once saved, a task can be changed, and all future executions of the task will reflect changes. You may want to edit which computers are affected by the task, or any other task parameter.

To edit a task schedule:
1 Select the Saved Tasks list.
2 Double-click a scheduled task in the Remote Desktop window.
3 Click the Schedule Task button.
4 Edit the task, or task schedule, as needed.
5 Click OK.

Deleting Scheduled Tasks
Unneeded tasks can be deleted. If you want to keep the task, but keep it from repeating, you should edit the scheduled task instead of deleting it. See Editing Scheduled Tasks for more information.

To delete a scheduled task:
1 Select the Saved Tasks list.
2 Select the desired task in the Remote Desktop window.
3 Press the Delete key.

UNIX Shell Commands
In addition to its own tasks, Apple Remote Desktop provides a way to easily execute UNIX commands on remote computers. In order to send UNIX commands to the client computers, the client computers must have the BSD subsystem installed. The UNIX commands are shell commands. This means that you can write a script with conditionals, loops, and other functions of the shell, and not just send one command.

Built-in Command-line Tools
Apple Remote Desktop includes two powerful command-line tools which can be used with Send UNIX Command: networksetup and systemsetup. The tools themselves are embedded within the ARD client software, and will not interfere with existing installations of the software on Mac OS X Server. The tools’ location is added to the default shell PATH, so you can access it through Remote Desktop as if it were installed in one of the standard UNIX tool locations. To change any settings using these tools, you must run them with root permissions (su root, or sudo).
networksetup
The command-line tool networksetup is used to configure a client’s network settings. It can create or modify network locations, change IP addresses, set network service proxies, and much more. You will find the command-line syntax, explanations, and an example in the tool’s help prompt, by entering the following as one line in Terminal:

/System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Support/networksetup -help

systemsetup
The command-line tool systemsetup is used to configure other non-network system settings. It can query or alter time zones, network time servers, sleep settings, Energy Saver preferences, Remote Login (ssh) preferences, and more. You will find the command-line syntax, explanations, and example in the tool’s help prompt, by entering the following as one line in the Terminal:

/System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Support/systemsetup -help

Executing a Single UNIX Command
Using the UNIX Command window, you can send a single command to the selected client computers. The command is executed using the bash shell and root permissions.

To execute a single UNIX command:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Manage > Send UNIX Command.
4 Type or paste the command.
   If your command is a multi-line script, enter each command on its own line. If you want to break up a single line command for better readability, use a back slash (\") to begin a new visual line.
5 Set the user whose permissions are used to execute the command.
   You can choose the currently logged in user, or choose the name of any other user known to exist on the client computers.
6 Click Send.

Executing Scripts Via UNIX Command
There are two kinds of scripts you can execute via the command line. First, and most common with command-lines, is a shell script. A shell script is a file that contains a collection of UNIX commands that are all executed in the sequence in the file. Shell scripts can have normal programming procedures like loops, conditionals, and variables. Shell scripts are text files with UNIX line endings. Shell scripts are interpreted using the bash shell.
Executing Shell Scripts
Shell scripts can be copied, then executed. If a script has any degree of complexity, or cannot be expressed on a single line, you can use Copy Items to copy the script file to the client computers, then execute it using the Send UNIX Command. To send a single-line command you can just use Send UNIX Command.

To copy and execute a script:
1. Prepare and save your script.
   Make sure your script is saved with UNIX line endings.
2. Open Remote Desktop.
3. Select a computer list.
4. Select one or more computers in the Remote Desktop window.
5. Use the Copy Items command to copy your script to the client computers.
6. After copying the script, choose Manage > Send UNIX Command.
7. Execute the script by typing:
   `sh [script path and name]`
8. Click Send.

AppleScripts
The second kind of script you can execute, and the most common in the Mac OS X environment, is an AppleScript. AppleScripts are files that contain English-like commands, using the AppleScript programming language, and are created using the Script Editor application. AppleScripts can be executed on client computers in several ways: they can be compiled, saved and executed as an application, or sent at once using the command line.

To learn more about AppleScript, see AppleScript Help in Help Viewer, or go to www.applescript.com.

To send and execute a compiled AppleScript:
1. Save the AppleScript as an application.
2. Open Remote Desktop.
3. Select a computer list.
4. Select one or more computers in the Remote Desktop window.
5. Use the Copy Items command to copy your script to the client machines.
   Use the Copy Items command with the Open After Copying option selected in the Copy Items dialog.
To execute an AppleScript using the Send UNIX Command:
This method uses the `osascript` command. For detailed information on `osascript`, see the `osascript` man page.
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Use the Copy Items command to copy your script to the client computers.
4 After copying the script, choose Manage > Send UNIX Command.
5 Type or paste the AppleScript in the UNIX Command window, like this:
   `osascript -e '[First line of script]' -e '[Next line of script]'`
   For example, a simple script to create a folder and set its label would be entered (all in one line) as:
   `osascript -e 'tell the application "Finder"'
   -e 'make new folder'
   -e 'set the name of the result to "New Folder"'
   -e 'set the label index of folder "New Folder" to 2'
   -e 'end tell'
6 Click Send.
   The client computer executes the script.
Interacting With Users

Apple Remote Desktop is a powerful tool for interacting with computer users across a network. You can interact by controlling or observing remote screens, text messaging with remote users, or sharing your screen with others.

This chapter describes the main aspects of ARD's user interaction capabilities and gives complete instructions for using them.

You can learn about:

- "Controlling" on page 94
- "Observing" on page 97
- "Sending Messages" on page 100
- "Sharing Screens" on page 102
Controlling
Apple Remote Desktop allows you to control remote computers as if you were sitting in front of them. You can only control the keyboard and mouse of any one computer at a time. There are two kinds of remote computers that ARD can control: ARD clients and Virtual Network Computing (VNC) servers.

Control Window Options
When controlling a client, you can see the client window at full size, or scaled to fit the control window. To switch between actual size and fitting to the window, click the Fit to Window button.

You can either take complete mouse and keyboard control or share control with an ARD client user. To switch between complete and shared control, click the Share Control button.

You can take a picture of the remote screen, and save it to a file. To take a screen shot of the remote computer, click the Screen Shot button.
Controlling ARD Clients

Apple Remote Desktop (ARD) client computers can be controlled by any administrator computer that has the “Control” permission set. See “ARD Administrator Access” on page 38 for more information about ARD permissions.

While controlling an ARD client computer, some keyboard shortcut commands are not sent to the remote computer, but affect the administrator computer. These include:

- Change Active Application (Cmd-Shift-Tab)
- Show or Hide Dock (Cmd-Option-D)
- Log Out User (Cmd-Shift-Q)
- Take Screen Shot (Cmd-Shift-3, -4)
- Force Quit (Cmd-Opt-Esc)

Also, special keys including the sound volume, screen brightness, and Media Eject keys do not affect the client computer.

These instructions assume the observed computer has ARD installed and configured properly (see “Installing the Client Software on Mac OS X 10.2 for the First Time” on page 28) and the computer has been added to an ARD computer list (see “About ARD Computer Lists” on page 57).

To control an ARD client:

1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
3. Choose Interact > Control.
   
   If the controlled computer’s screen is larger than your control window, the screen will scroll as the pointer approaches the edge of the window.
4. To toggle between viewing full size and fitting to the window, click the Fit to Window button.
5. Use your mouse and keyboard to perform actions on the controlled computer.
   
   If your ARD preferences are set to share keyboard and mouse control, the remote computer’s keyboard and mouse are active and affect the computer just as the administrator computer’s keyboard and mouse do.
   
   If your preferences aren’t set to share control, the remote computer’s keyboard and mouse do not function while the administrator computer is in control.

Note: If you are observing a client, you can click the Share Control button to switch to controlling that client.
Controlling VNC Servers

Virtual Network Computing (VNC) is remote control software. It allows a user at one computer (using a “viewer”) to view the desktop and control the keyboard and mouse of another computer (using a VNC “server”) connected via the network. For the purposes of these instructions, VNC-enabled computers are referred to as “VNC clients.”

VNC servers and viewers are available for a variety of computing platforms. ARD is a VNC viewer and can therefore control any computer on the network (whether that computer be running Mac OS X, Linux, or Windows) that is:

- Running the VNC server software
- In an ARD computer list

These instructions assume the observed computer has been added to an ARD computer list (see [About ARD Computer Lists on page 57]). When adding a VNC server to an ARD computer list, you only need to provide the VNC password and no user name.

To control a VNC client computer:

1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
3. Choose Interact > Control.
   
   If the controlled computer’s screen is larger than your control window’s, the screen will scroll as the pointer approaches the edge of the window.
4. To switch between viewing full size and fitting to the window, click the Fit to Window button.
5. Use your mouse and keyboard to perform actions on the controlled computer.

Regardless of your Apple Remote Desktop preferences, controlled VNC servers share keyboard and mouse control. The remote computer’s keyboard and mouse are active and affect the computer just as the administrator computer’s keyboard and mouse do.

**Note:** If you are observing a client, you can click the Share Control button to switch to controlling that client.

Configuring an ARD Client to Be Controlled by a VNC Viewer

When configured to do so, an Apple Remote Desktop client can be controlled with a non-Apple Virtual Network Computing (VNC) viewer.

Allowing a non-Apple VNC viewer access to an ARD client is less secure than using Remote Desktop to control the client. The non-Apple VNC software expects the password to be stored in a cryptographically unsecure form and location.

Chapter 4  Interacting With Users
To configure a client to accept VNC connections:
1 On the client computer, open System Preferences.
2 Open Remote Desktop preferences.
   On a Mac OS X 10.2 client, click Remote Desktop
   On a Mac OS X 10.3 client, click Sharing, select Apple Remote Desktop, then click Access Privileges.
3 Select “VNC viewers may control screen with the password.”
4 Enter a VNC password.
5 Click OK.

Warning: Do not use the same password as any user or ARD administrator. The password may not be secure.

Observing
You may not want to control a computer, but merely monitor what is on its screen. Observing a remote computer is similar to controlling one, except your mouse movements and keyboard input are not sent to the remote computer. Apple Remote Desktop client computers can be observed by any administrator computer that has the “Observe” permission set. See "ARD Administrator Access" on page 33 for more information about ARD permissions.
ARD allows you to observe multiple clients on the same screen, rotating through the list of observed computers. This allows you to monitor many screens without having to select each one individually.

When observing a single client, you can see the client window at full size, or scaled to fit the observe window. To switch between actual size and fitting to the window, click the Fit to Window button, just as you would in a control window.

If you’re observing more clients than you’ve chosen to fit on one screen, you can rotate through multiple pages by clicking the Forward and Back buttons.

**Changing Observe Settings While Observing**

While you are observing multiple computers, you can adjust the Apple Remote Desktop observe settings using the controls at the top of the observe window.

To change your observe settings:

- Adjust the number of client screens visible on each page.

- Adjust the number of seconds before automatically advancing to the next page of screens.
• Adjust the screen color depth from black and white to millions of colors.

Shortcuts in the Multiple Screen Observe Window
You can access several Apple Remote Desktop commands using icons in the observe window. You can access the Copy Items command and the Text Chat command using the buttons in the observe window toolbar. You can also perform ARD tasks on any computer by selecting its screen and choosing a task from the Remote Desktop menus.

Observing a Single Computer
When you observe a single computer, the observed screen appears in a window on your administrator computer. If a screen saver is active when you observe the screen, the screen saver remains in effect. The observe window contains a Share Control button to switch to controlling the screen.

These instructions assume the observed computer has Apple Remote Desktop installed and configured properly (see Installing the Client Software on Mac OS X 10.2 for the First Time on page 28) and the computer has been added to an ARD computer list (see About ARD Computer Lists on page 57).

To observe a single computer:
1 Select a computer list.
2 Select a computer in the Remote Desktop window.
3 Choose Interact > Observe.
   If the observed computer’s screen is larger than the observe window, the screen will scroll as the pointer approaches the edge of the window.
4 To switch between observing at actual size and fitting to the window, click the Fit to Window button.
   If you are observing clients, you can double-click an observed screen to switch to controlling that client.

Observing Multiple Computers
When you observe multiple client computers, each client screen is scaled down, so that several computers can be viewed at the same time. You can set the number of client screens that appear at any one time. See Setting Preferences for the Remote Desktop Application on page 47 for more information.

If a client is asleep or has a screen saver in effect when you start observing, the screen saver is not dismissed.
The screens will rotate through the entire list of selected computers, a few at a time, switching every 30 seconds. The following keystrokes allow you to alter that cycle:

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right Arrow</td>
<td>Show the next group of screens now</td>
</tr>
<tr>
<td>Left Arrow</td>
<td>Show the previous group of screens now</td>
</tr>
<tr>
<td>Space bar</td>
<td>Stop and start rotating through screens</td>
</tr>
</tbody>
</table>

**To observe multiple computers:**
1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
3. Choose Interact > Observe.

The remote computer screens appear in a window.

**Sending Messages**
Apple Remote Desktop allows you to communicate with users of ARD client computers using text messaging. You can use text messages to give instructions or announcements, to remotely collaborate, or troubleshoot with users. There are two types of text messaging: one-way messages and two-way, interactive chat. Text messages and chat are available only to ARD client computers; they are not available to VNC client computers.

**Sending One-Way Messages**
You can use a one-way text message to send announcements or information to ARD client computer users. The announcements appear in front of open application windows and can be dismissed by the user.

**To send a one-way text message:**
1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
3. Choose Interact > Send Message.
4. Enter your message.
5. Click Send.

The text message appears on the screen of all the selected computers.

**Interactive Chat**
You can start an interactive text chat with a user at an ARD client computer. This allows you instant feedback from users, so you can collaborate or troubleshoot.
To begin an interactive chat:
1. Select a computer list.
2. Select one or more computers in the Remote Desktop window.
4. Enter your message, one line at a time.
5. Press the Return key after each line to send the message.

**Requesting Administrator Attention**
At times, ARD client computer users need to get the attention of the ARD administrator. If an ARD administrator is currently monitoring the client computer, the client user can send an attention request.

To request administrator attention:
1. Click the Finder icon in the Dock.
2. Locate the ARD status icon in the menu bar.
3. Click the ARD status icon and choose Message to Administrator.
   The attention request window appears.
4. If the network has more than one ARD administrator available, choose the administrator to whom the request will be sent from the “Send request to” pop-up menu.
5. Enter the message.
6. Click Send.
   The attention request icon appears on the administrator’s screen.

**Canceling an Attention Request**
If a user decides that he or she doesn't need the ARD administrator's attention, he or she can cancel the attention request after it has been sent.

To cancel an attention request:
1. Click the Finder icon in the Dock.
2. Locate the ARD status icon in the menu bar.
3. Click the ARD status icon and choose Cancel Message to Administrator.
**Viewing Attention Requests**

After a client user sends an attention request, the ARD administrator can read the attention request text.

**To view attention requests:**

1. Choose Window > Messages From Users.
2. Double-click the listed request to view the request’s message.

**Sharing Screens**

Apple Remote Desktop allows you to show your screen (or the screen of a client computer in your list) to any or all ARD client computers in the same computer list. You can, for example, show a presentation to a classroom of computers from a single computer.

**Sharing a Screen With a Single Client**

You can share a client computer’s screen, or the administrator’s screen, with a single client. The client screen displays what is on the shared screen, but cannot control it in any way.

**To share a computer’s screen with a single client:**

1. Select a computer list.
2. Select a computer in the Remote Desktop window.
3. Choose Interact > Share Screen.
4. Select the screen to be shared.
   - If you want to share the ARD administrator’s screen, select “Send your screen to target computers.”
   - If you want to share another client’s screen, select “Send other screen to target computers,” and drag a computer from an ARD computer list to the dialog.
5. Click Share Screen.

The selected screen shows the shared computer’s screen.

If the client computer’s screen resolution is lower than the shared computer’s, only the top left part of the shared screen (up to the lowest screen resolution) will be seen on the receiving screen.
Sharing a Screen With Multiple Clients
You can share a client’s screen, or the administrator’s screen, with any number of clients. The client screens all display what is on the sending screen, but cannot control it in any way.

To share a computer’s screen with multiple clients:
1 Select a computer list.
2 Select one or more computers in the Remote Desktop window.
3 Choose Interact > Share Screen.
4 Select the screen to be shared.
   If you want to share the ARD administrator’s screen, select “Send your screen to target computers.”
   If you want to share another client’s screen, select “Send other screen to target computers,” and drag a computer from an ARD computer list to the dialog.
5 Click Share Screen.

The selected screens will show the shared computer’s screen.
If any client computer’s screen resolution is lower than the shared computer’s, only the top left part of the shared screen (up to the lowest screen resolution) will be seen on the receiving screen.
Computer Scanner Icons
The following icons appear next to the names of computers in a scanner search results list. The icons show the status of each computer.

<table>
<thead>
<tr>
<th>Icon</th>
<th>What it means</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="access" /></td>
<td>Accessible to ARD</td>
</tr>
<tr>
<td><img src="image" alt="offline" /></td>
<td>Offline ARD client</td>
</tr>
<tr>
<td><img src="image" alt="ping" /></td>
<td>Ping response at IP address, but no ARD client response</td>
</tr>
<tr>
<td><img src="image" alt="offline_noard" /></td>
<td>Offline non-ARD client</td>
</tr>
<tr>
<td><img src="image" alt="no_password" /></td>
<td>No login name or password stored for this computer</td>
</tr>
<tr>
<td><img src="image" alt="denied" /></td>
<td>Access denied</td>
</tr>
<tr>
<td><img src="image" alt="vnc" /></td>
<td>VNC server available</td>
</tr>
<tr>
<td><img src="image" alt="attention" /></td>
<td>User requests attention</td>
</tr>
</tbody>
</table>
ARD Status Icons
The ARD status icon appears in the menu bar of each ARD client. The status icon has several states, depending on the status of the client computer.

<table>
<thead>
<tr>
<th>Icon</th>
<th>What it means</th>
</tr>
</thead>
</table>
| ![icon](image) | Not Active  
ARD has been installed but is not currently running on the client computer. |
| ![icon](image) | Ready  
ARD is installed and running on the client. |
| ![icon](image) | Administered  
ARD is installed and running on the client computer, and the administrator is currently performing an ARD task on the client. |

TCP and UDP Port Reference
ARD uses the following TCP and UDP ports for the functions indicated.

<table>
<thead>
<tr>
<th>Port</th>
<th>Protocol</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>5900</td>
<td>TCP</td>
<td>Observe/Control</td>
</tr>
<tr>
<td>5900</td>
<td>UDP</td>
<td>Send Screen</td>
</tr>
<tr>
<td>3283</td>
<td>TCP</td>
<td>Reporting</td>
</tr>
<tr>
<td>3283</td>
<td>UDP</td>
<td>Everything Else</td>
</tr>
<tr>
<td>5988</td>
<td>TCP</td>
<td>WBEM (only if enabled)</td>
</tr>
</tbody>
</table>
Report Field Definitions Reference

The following sections describe the available fields in each of the ARD reports. For information on generating reports, see [Creating reports on page 66](#).

**System Overview Report**

<table>
<thead>
<tr>
<th>List Category</th>
<th>Field Name</th>
<th>Notes or Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>AirPort</td>
<td>AirPort Active</td>
<td>Yes/No</td>
</tr>
<tr>
<td></td>
<td>AirPort Firmware Version</td>
<td>Version number</td>
</tr>
<tr>
<td></td>
<td>AirPort Hardware Address</td>
<td>00:30:65:01:79:EC</td>
</tr>
<tr>
<td></td>
<td>AirPort Locale</td>
<td></td>
</tr>
<tr>
<td></td>
<td>AirPort Type</td>
<td></td>
</tr>
<tr>
<td></td>
<td>AirPort Installed</td>
<td>Yes/No</td>
</tr>
<tr>
<td></td>
<td>AirPort Network Channel</td>
<td>Channel number 1-11</td>
</tr>
<tr>
<td></td>
<td>AirPort Network in Range</td>
<td>Network name</td>
</tr>
<tr>
<td>AppleTalk</td>
<td>AppleTalk active</td>
<td>Yes/No</td>
</tr>
<tr>
<td></td>
<td>AppleTalk Network</td>
<td></td>
</tr>
<tr>
<td></td>
<td>AppleTalk Node</td>
<td></td>
</tr>
<tr>
<td></td>
<td>AppleTalk Zone</td>
<td></td>
</tr>
<tr>
<td>Computer</td>
<td>Active Processors</td>
<td>Number of processors</td>
</tr>
<tr>
<td></td>
<td>Available user memory</td>
<td>Memory in KB</td>
</tr>
<tr>
<td></td>
<td>Boot ROM</td>
<td>ROM version number</td>
</tr>
<tr>
<td></td>
<td>Bus Clock Speed</td>
<td>in MHz</td>
</tr>
<tr>
<td></td>
<td>Bus Data Size</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CPU Speed</td>
<td>in MHz</td>
</tr>
<tr>
<td></td>
<td>Serial number</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Velocity Engine</td>
<td>Yes/No</td>
</tr>
<tr>
<td></td>
<td>L2 Cache Size</td>
<td>in KB</td>
</tr>
<tr>
<td></td>
<td>L3 Cache Size</td>
<td>in KB</td>
</tr>
<tr>
<td>Machine Class</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Machine Model</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Memory</td>
<td>in KB</td>
</tr>
<tr>
<td></td>
<td>Open RAM slots</td>
<td></td>
</tr>
<tr>
<td></td>
<td>PCI slots</td>
<td></td>
</tr>
<tr>
<td></td>
<td>PCI slots used</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Processor Count</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Processor Type</td>
<td>internal value</td>
</tr>
<tr>
<td></td>
<td>Sales order number</td>
<td></td>
</tr>
<tr>
<td>List Category</td>
<td>Field Name</td>
<td>Notes or Example</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------</td>
<td>------------------</td>
</tr>
<tr>
<td>VM Size</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Total RAM Slots</td>
<td></td>
</tr>
<tr>
<td>Devices</td>
<td>ATA Device Count</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Firewire Device Count</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Keyboard Connected</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mouse Connected</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Optical Drive Type</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SCSI Device Count</td>
<td></td>
</tr>
<tr>
<td></td>
<td>USB Device Count</td>
<td></td>
</tr>
<tr>
<td>Display</td>
<td>2nd Monitor Depth</td>
<td>bits</td>
</tr>
<tr>
<td></td>
<td>2nd Monitor Type</td>
<td></td>
</tr>
<tr>
<td></td>
<td>2nd Monitor Size</td>
<td>pixels vertical</td>
</tr>
<tr>
<td></td>
<td>2nd Monitor Size</td>
<td>pixels horizontal</td>
</tr>
<tr>
<td></td>
<td>Monitor Depth</td>
<td>bits</td>
</tr>
<tr>
<td></td>
<td>Monitor Flags</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Monitor Size</td>
<td>pixels vertical</td>
</tr>
<tr>
<td></td>
<td>Monitor Size</td>
<td>pixels horizontal</td>
</tr>
<tr>
<td>Modem</td>
<td>Modem Country</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Modem Driver Info</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Modem Firmware Version</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Modem Installed</td>
<td>Yes/No</td>
</tr>
<tr>
<td></td>
<td>Modem Interface</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Modem Model</td>
<td></td>
</tr>
<tr>
<td>Network</td>
<td>First Ethernet Address</td>
<td>en0 MAC address</td>
</tr>
<tr>
<td></td>
<td>Machine is NetBooted</td>
<td>Yes/No</td>
</tr>
<tr>
<td></td>
<td>Primary IP Address</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Primary network collisions</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Primary network flags</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Primary network hardware address</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Primary Network Input Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Primary Network Input Packets</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Primary Network Output Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Primary Network Output Packets</td>
<td></td>
</tr>
<tr>
<td>Preferences</td>
<td>Sleep Display</td>
<td>Yes/No</td>
</tr>
</tbody>
</table>
### List Category

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Notes or Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sleep Hard Disk</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Sleep Computer</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Wake for Ethernet Access</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Printing</td>
<td></td>
</tr>
<tr>
<td>Printer Name</td>
<td></td>
</tr>
<tr>
<td>Printer Sharing</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Printer Type</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Remote Desktop</td>
<td></td>
</tr>
<tr>
<td>Computer Info #1</td>
<td></td>
</tr>
<tr>
<td>Computer Info #2</td>
<td></td>
</tr>
<tr>
<td>Computer Info #3</td>
<td></td>
</tr>
<tr>
<td>Computer Info #4</td>
<td></td>
</tr>
<tr>
<td>Sharing</td>
<td></td>
</tr>
<tr>
<td>Computer Name</td>
<td>Sharing name</td>
</tr>
<tr>
<td>FTP Access</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Remote AppleEvents</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Remote Login</td>
<td>Yes/No</td>
</tr>
<tr>
<td>UNIX Hostname</td>
<td>foo.example.com</td>
</tr>
<tr>
<td>Web Sharing</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Windows File Sharing</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Software</td>
<td></td>
</tr>
<tr>
<td>Kernel Version</td>
<td></td>
</tr>
<tr>
<td>System Version</td>
<td>Mac OS X 10.3 (7B62)</td>
</tr>
<tr>
<td>System Version (Non Display Field)</td>
<td>internal number</td>
</tr>
<tr>
<td>Storage</td>
<td></td>
</tr>
<tr>
<td>Free Disk Space</td>
<td>in KB, MB, or GB</td>
</tr>
<tr>
<td>Total Disk Space</td>
<td>in KB, MB, or GB</td>
</tr>
<tr>
<td>Trash Size</td>
<td>in KB, MB, or GB</td>
</tr>
</tbody>
</table>

### Storage Report

<table>
<thead>
<tr>
<th>List Category</th>
<th>Name</th>
<th>Notes or Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware Options</td>
<td>Logical Unit Number</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Detachable</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Drive Manufacturer</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Drive Model</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Drive Revision</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Drive Protocol</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Removable</td>
<td>Yes/No</td>
</tr>
<tr>
<td></td>
<td>Serial Number</td>
<td></td>
</tr>
</tbody>
</table>
### List Category

<table>
<thead>
<tr>
<th>Name</th>
<th>Notes or Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Volume Options</td>
<td></td>
</tr>
<tr>
<td>Creation date</td>
<td>UNIX GMT format</td>
</tr>
<tr>
<td>Disk Name</td>
<td>Macintosh HD</td>
</tr>
<tr>
<td>File Count</td>
<td></td>
</tr>
<tr>
<td>Folder Count</td>
<td></td>
</tr>
<tr>
<td>Free Space</td>
<td>in KB, MB, or GB</td>
</tr>
<tr>
<td>Startup Disk</td>
<td></td>
</tr>
<tr>
<td>Total Disk Space</td>
<td></td>
</tr>
<tr>
<td>UNIX Mount Point</td>
<td>/dev/disk0s10</td>
</tr>
<tr>
<td>File System Options</td>
<td></td>
</tr>
<tr>
<td>Disk Format</td>
<td>HFS, HFS+, UFS</td>
</tr>
<tr>
<td>Case Sensitive</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Preserves Case</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Write Access</td>
<td></td>
</tr>
<tr>
<td>Modification date</td>
<td>UNIX GMT format</td>
</tr>
<tr>
<td>Permissions</td>
<td></td>
</tr>
<tr>
<td>Owner</td>
<td></td>
</tr>
<tr>
<td>Permission Modes</td>
<td></td>
</tr>
<tr>
<td>Permissions</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Backup Options</td>
<td></td>
</tr>
<tr>
<td>Journaling Capable</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Journaled</td>
<td>Yes/No</td>
</tr>
<tr>
<td>Last Backup date</td>
<td>UNIX GMT format</td>
</tr>
<tr>
<td>Last Check date</td>
<td>UNIX GMT format</td>
</tr>
</tbody>
</table>

### Memory Report

<table>
<thead>
<tr>
<th>Name</th>
<th>Notes or Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location</td>
<td>DIMM0/J21</td>
</tr>
<tr>
<td>Size</td>
<td>in MB</td>
</tr>
<tr>
<td>Speed</td>
<td>PC133-222 (Mac OS X 10.3 only)</td>
</tr>
<tr>
<td>Type</td>
<td>SDRAM</td>
</tr>
</tbody>
</table>

### PCI Cards Report

<table>
<thead>
<tr>
<th>Name</th>
<th>Notes or Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slot Name</td>
<td>Slot4</td>
</tr>
<tr>
<td>Card Type</td>
<td>display</td>
</tr>
<tr>
<td>Card Name</td>
<td></td>
</tr>
<tr>
<td>Vendor ID</td>
<td></td>
</tr>
<tr>
<td>Device ID</td>
<td></td>
</tr>
</tbody>
</table>
### FireWire Devices Report

<table>
<thead>
<tr>
<th>Name</th>
<th>Notes or Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ROM Revision</td>
<td>Displays only</td>
</tr>
<tr>
<td>Card Revision</td>
<td></td>
</tr>
<tr>
<td>Card Memory</td>
<td>Displays only</td>
</tr>
</tbody>
</table>

### USB Devices Report

<table>
<thead>
<tr>
<th>Name</th>
<th>Notes or Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device Speed</td>
<td>200, 400, 800</td>
</tr>
<tr>
<td>Software Version</td>
<td></td>
</tr>
<tr>
<td>Manufacturer</td>
<td></td>
</tr>
<tr>
<td>Model</td>
<td></td>
</tr>
<tr>
<td>Firmware Revision</td>
<td></td>
</tr>
</tbody>
</table>

### Network Interfaces Report

<table>
<thead>
<tr>
<th>List Category</th>
<th>Name</th>
<th>Notes or Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Overview</td>
<td>Name</td>
<td>Location name</td>
</tr>
<tr>
<td></td>
<td>Active</td>
<td>Yes/No</td>
</tr>
<tr>
<td></td>
<td>Primary</td>
<td>Yes/No</td>
</tr>
<tr>
<td></td>
<td>Configured With</td>
<td>Ethernet</td>
</tr>
<tr>
<td></td>
<td>Hardware Address</td>
<td>00:30:65:01:79:EC</td>
</tr>
<tr>
<td></td>
<td>Interface Name</td>
<td>en0</td>
</tr>
<tr>
<td></td>
<td>Flags</td>
<td></td>
</tr>
<tr>
<td>Active Interface Options</td>
<td>Domain</td>
<td>example.com</td>
</tr>
<tr>
<td></td>
<td>Router Address</td>
<td></td>
</tr>
<tr>
<td></td>
<td>IP Address</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Broadcast Address</td>
<td></td>
</tr>
<tr>
<td>List Category</td>
<td>Name</td>
<td>Notes or Example</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------------------------------</td>
<td>-----------------------------------------</td>
</tr>
<tr>
<td>DNS Server</td>
<td>DNS Server</td>
<td></td>
</tr>
<tr>
<td>Subnet Mask</td>
<td>Subnet Mask</td>
<td></td>
</tr>
<tr>
<td>IP Addresses</td>
<td>IP Addresses</td>
<td></td>
</tr>
<tr>
<td>Broadcast Addresses</td>
<td>Broadcast Addresses</td>
<td></td>
</tr>
<tr>
<td>DNS Servers</td>
<td>DNS Servers</td>
<td></td>
</tr>
<tr>
<td>Subnet Masks</td>
<td>Subnet Masks</td>
<td></td>
</tr>
<tr>
<td>Network Statistics</td>
<td>Network Collisions</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Network Input Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Network Input Packets</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Network Output Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Network Output Packets</td>
<td></td>
</tr>
<tr>
<td>Output Statistics</td>
<td>Output Queue Capacity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Output Queue Size</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Output Queue Peak Size</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Output Queue Drop Count</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Output Queue Output Count</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Output Queue Retry Count</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Output Queue Stall Count</td>
<td></td>
</tr>
<tr>
<td>Ethernet Statistics</td>
<td>Ethernet Alignment Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet FCS Errors</td>
<td>Frame Check Sequence errors</td>
</tr>
<tr>
<td></td>
<td>Ethernet Single Collision Frames</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Multiple Collision Frames</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet SQE Test Errors</td>
<td>“heartbeat” test errors</td>
</tr>
<tr>
<td></td>
<td>Ethernet Deferred Transmissions</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Late Collisions</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Excessive Collisions</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Internal Mac Transmit Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Carrier Sense Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Frame Too Long</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Internal Mac Receive Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet etherChipSet</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Missed Frames</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Receiver Overruns</td>
<td></td>
</tr>
<tr>
<td>List Category</td>
<td>Name</td>
<td>Notes or Example</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td></td>
<td>Ethernet Receiver Watchdog</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Timeouts</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Receiver Frame Too Short</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Receiver Collision Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Receiver PHY Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Receiver Timeouts</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Receiver Interrupts</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Receiver Resets</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Receiver Resource Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Transmitter Underruns</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Transmitter Jabbers</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Transmitter PHY Errors</td>
<td>Physical Errors</td>
</tr>
<tr>
<td></td>
<td>Ethernet Transmitter Timeouts</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Transmitter Interrupts</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Transmitter Resets</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Transmitter Resource Errors</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ethernet Collision Frequencies</td>
<td></td>
</tr>
</tbody>
</table>

Appendix A Reference
**PostgreSQL Schema Sample**

**Sample list of main database schema**

```
/System/Library/CoreServices/RemoteManagement/rmdb.bundle/bin/psql -U ard -c "\d propertynamemap" ard
```

Table "public.propertynamemap"

<table>
<thead>
<tr>
<th>Column</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>objectname</td>
<td>character varying(128)</td>
<td>not null</td>
</tr>
<tr>
<td>propertyname</td>
<td>character varying(128)</td>
<td>not null</td>
</tr>
<tr>
<td>propertymapid</td>
<td>integer</td>
<td></td>
</tr>
</tbody>
</table>

**Sample list of system information table**

```
/System/Library/CoreServices/RemoteManagement/rmdb.bundle/bin/psql -U ard -c "\d systeminformation" ard
```

Table "public.systeminformation"

<table>
<thead>
<tr>
<th>Column</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>computerid</td>
<td>character(17)</td>
<td>not null</td>
</tr>
<tr>
<td>objectname</td>
<td>character varying(128)</td>
<td>not null</td>
</tr>
<tr>
<td>propertyname</td>
<td>character varying(128)</td>
<td>not null</td>
</tr>
<tr>
<td>itemseq</td>
<td>integer</td>
<td></td>
</tr>
<tr>
<td>value</td>
<td>character varying(512)</td>
<td></td>
</tr>
<tr>
<td>lastupdated</td>
<td>timestamp with time zone</td>
<td></td>
</tr>
</tbody>
</table>

**Sample list of property names**

```
/System/Library/CoreServices/RemoteManagement/rmdb.bundle/bin/psql -U ard -c "select * from propertynamemap" ard
```

<table>
<thead>
<tr>
<th>objectname</th>
<th>propertyname</th>
<th>propertymapid</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mac_SystemInfoElement</td>
<td>WirelessCardIsActive</td>
<td>0</td>
</tr>
<tr>
<td>Mac_SystemInfoElement</td>
<td>WirelessCardFirmwareVersion</td>
<td>1</td>
</tr>
<tr>
<td>Mac_SystemInfoElement</td>
<td>WirelessCardHardwareAddress</td>
<td>2</td>
</tr>
<tr>
<td>Mac_SystemInfoElement</td>
<td>WirelessCardLocale</td>
<td>3</td>
</tr>
<tr>
<td>Mac_SystemInfoElement</td>
<td>WirelessCardType</td>
<td>4</td>
</tr>
<tr>
<td>Mac_SystemInfoElement</td>
<td>WirelessCardInstalled</td>
<td>5</td>
</tr>
<tr>
<td>Mac_SystemInfoElement</td>
<td>WirelessChannelNumber</td>
<td>6</td>
</tr>
<tr>
<td>Mac_SystemInfoElement</td>
<td>WirelessNetworkAvailable</td>
<td>7</td>
</tr>
<tr>
<td>Mac_SystemInfoElement</td>
<td>WirelessIsComputerToComputer</td>
<td>8</td>
</tr>
</tbody>
</table>

......
Sample list of table from one computer

```bash
/System/Library/CoreServices/RemoteManagement/rmdb.bundle/bin/psql -U ard -c
"select * from systeminformation" ard
```

<table>
<thead>
<tr>
<th>computerid</th>
<th>objectname</th>
<th>propertyname</th>
<th>itemsq</th>
<th>value</th>
<th>lastupdated</th>
</tr>
</thead>
<tbody>
<tr>
<td>00:03:93:af:15:cc</td>
<td>Mac_HardDriveElement</td>
<td>CreationDate</td>
<td>0</td>
<td>2004-02-25T03:30:07Z</td>
<td>2004-02-26 22:21:38-08</td>
</tr>
<tr>
<td>00:03:93:af:15:cc</td>
<td>Mac_HardDriveElement</td>
<td>FileSystemType</td>
<td>0</td>
<td>18475</td>
<td>2004-02-26 22:21:38-08</td>
</tr>
<tr>
<td>00:03:93:af:15:cc</td>
<td>Mac_HardDriveElement</td>
<td>FreeSpace</td>
<td>0</td>
<td>4101610</td>
<td>2004-02-26 22:21:38-08</td>
</tr>
<tr>
<td>00:03:93:af:15:cc</td>
<td>Mac_HardDriveElement</td>
<td>GroupName</td>
<td>0</td>
<td>admin</td>
<td>2004-02-26 22:21:38-08</td>
</tr>
</tbody>
</table>